Exchange Receive Connector 530 Error

I am not able to receive any external email.   I telnet into the server telnet mail.mycompany.com 587, HELO gets response, MAIL FROM: email@mydomain.com gets;

530 5.7.1 Client was not authenticated
Connection closed by foreign host.

I verified that Anonymous was enabled in the receive connector, I even deleted and recreated the Receive Connector.

Nothing of note in the Eventlogs.

Any Ideas?

Thanks
LVL 2
BMardenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BMardenAuthor Commented:
Sorry should have mentioned Exchange 2010 running on Server 2008R2
0
BMardenAuthor Commented:
Okay, I solve my own issue...

I put in a new router today and one of the port forwards listens on TCP 587 (public) and forwards to TCP 25 (private), well apparently the dumb router is not listening to instructions and is forwarding on port 587 (private) which is going to Client Receive connector listening on 587 and does not have Anonymous enabled.

I knew something was up when I disabled the Default Receive connector and still got a response to telnet connection.

Thanks
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rezwan IslamSystems AdministratorCommented:
External emails will be received on port 25. Default receive connector use port 25. Other connector is for non-MAPI clients such as POP and IMAP. Check to see if you have "Anonymous users" ticked in the permission groups tab or using EMS,
Get-ReceiveConnector -Identity "<Server name>\Default connector name" | fl PermissionGroups

then tick it if it is not. Hope this works.
0
BMardenAuthor Commented:
Solved own issue
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.