Set up wireless in Slackware

I need a simple step-by-step instruction to setting up a wireless client in Slackware. Believe it or not, I've set up a wireless Master in Slackware, but the Managed mode is defeating me. As I [mis]understand things thus far, there are wireless settings in /etc/rc.d/rc.inet1.conf, but rc.inet1 runs rc.wireless which basically runs iwconfig using settings  in etc/rc.d/rc.wireless.conf, but iwconfig cannot set the WPA password -- that has to be done with wpa_supplicant also run from rc.wireless? with its own /etc/wpa_supplicant.conf?

OK, I'm lost! I have 3 parameters: wlan0, ESSID = myESSID, and password = myPassword; what do I set in one or more of /etc/rc.d/inet1.conf, /etc/rc.d/wireless.conf and/or /etc/wpa_supplicant.conf, and wherever else as needed to get this working?

Thanks!
LVL 1
jmarkfoleyAsked:
Who is Participating?
 
nociSoftware EngineerCommented:
first for managed mode you will need wpa_supplicant. This can handle everything that is needed.
For managing the Wifi connection.

To be sure we're on the same page
http://docs.slackware.com/slackbook:wifi
And look for the chapter "Wifi Protected Access"  (wpa). It mentions an wpa setup file.

wpa_supplicant has it's own config file: /etc/wpa_supplicant.conf

The needed changes in rc_inet1.conf are mentioned after that, with guidance.

Dont dive into wicd before you have a better understanding of networking.
0
 
jmarkfoleyAuthor Commented:
> Dont dive into wicd before you have a better understanding of networking.

I've been doing network management for years and, as I mentioned, have set up several wireless Masters on both Slackware, Debian and Raspian. I've also set up a wireless client on Ubuntu. It's not networking I don't understand, just the myriad of confusing programs, scripts and config files on Slackware. While I favor Slackware generally, this particular setup has me scratching my head. I'll check out your link and post back with results.

Thanks.
0
 
jmarkfoleyAuthor Commented:
Well, that was a snap! Basically the same 6 settings I had already sorted out in /etc/rc.d/rc.inet1.conf:
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
WLAN_ESSID[4]=myESSID
WLAN_WPA[4]="wpa_supplicant"

Open in new window

And the /etc/wpa_supplicant.conf example supplied in the link, which I'll reproduce here for future lost boys:
# /etc/wpa_supplicant.conf
# ========================
# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
#country=US

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=1
  ssid="mySSID"
  key_mgmt=WPA-PSK
  psk="myPassKey"
}

Open in new window

All I needed to do then was `/etc/rc.d/rc.init wlan0_start`

THAT'S what I was looking for! Some one simple place that I could see exactly what needs to be set and where. I searched all over for this with no luck.

Thanks for the link to http://docs.slackware.com/slackbook:wifi. I've never used SLACKBOOK before, and I believe it will be very useful.

I will try the link's recommended wired and wireless network connection manager wicd in the near future. That look like exactly what I want for managing connection to multiple wireless networks at this computer is destined to travel a lot.
0
 
nociSoftware EngineerCommented:
agree,but you need to know more about the network plumbing for that.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.