Link to home
Start Free TrialLog in
Avatar of Network Zero
Network ZeroFlag for United States of America

asked on

Puppet I can't find the address that is being assigned to the Machine using facter

I'm following the "Learn Puppet PDF and I've used both vmplayer 7 and now vmware workstation 11 both in bridged mode,

I've tired literally everything I can think of I even created a reservation using the mac address in my DHCP server running on windows 2012 r2.

it looks like it's getting the loop backup address 127.0.0.1


User generated image
User generated image
User generated image
Avatar of Network Zero
Network Zero
Flag of United States of America image

ASKER

The system is running on centos 6.5
Avatar of Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Install VMware Tools in the Virtual Machine.

Click the button in your screenshot and then..

See my EE Article for Linux

Part 9: HOW TO: Install VMware Tools for Linux on a VMware Linux virtual machine on a VMware vSphere Hypervisor 5.1 (ESXi 5.1) Host Server
Hmmm @ Andrew, My problem is not installing vmware tools my problem is that I can't an ip address in centos there is no guest operating system so It wont let me install the guest operating system.

Will installing Vmware tools fix my ip issue?
ASKER CERTIFIED SOLUTION
Avatar of Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Hey Andrew!

I finally figured out what the problem was...

Mine was using an 8254 EM, -- I used that command to find out

lspci -nn | grep -i net

You see the main issue here is that this VM wasn't created by me it was created by the company Puppet themselves to learn puppet.

I started just troubleshooting nic card issues and virtual nic card issues

I went ahead and removed the vm since I had nothing going on and started over same issue...

so then I moved on and looked at everything going on in the console...

and I saw this ---> Determining IP information for eth0... failed; no link present. Check cable

I researched the issue..

I looked at the physical hardware and virtual and remember I had a virtual switch set up that was being used for hyper V

so I removed the switch and re-confirmed everything was on bridge mode

and made it so it only was able to select my Ethernet card and bamm I have an IP address now and I moved on to the next step which is going in via SHH which now works :)

Puppet here I come :)

Thanks for your advise Andrew!
puppetfix.png
pupperfix2.png
Helped me figure out enough steps to troubleshoot the issue and figure out the problem.