Windows folder sharing problem in 7 & Vista

I have a client that has 6 windows pcs. 2 are windows 8, 3 are windows 7 and one is windows vista. They are using a peer to peer setup with no server. All their shared files reside on one of the windows 7 pcs which is not used by anyone else and is 'considered' their 'file server' even though it is running W7. Up until last week they put all their files in one folder on this W7 pc. Everyone had access to it because there was no real security on it. Meaning no one had a login account on this W7 pc. Last week they called me in and wanted me to restrict access to the main folder we will just call 'company docs' for now due to the fact that they had a new employee starting. The client wanted me to create a new folder called 'company docs 2' on this W7 pc and give full access to everyone. The client would move whatever docs were needed to be shared with the new employee to the new folder and the rest of the office would have access to the original folder. I added everyone to the W7 pc as users with admin rights. Created the new folder. Confirmed that the new folder's security had the everyone group having full rights. I deleted the EVERYONE group from the shared folders rights and then added each employee to it and gave them full rights except the new employee. All was good after a reboot except the Vista computer. No matter what I did after I removed the everyone group, I couldn't get that computer to see the original company docs folder. Everyone else could.

So how do I get this Vista computer to see the shared folder and remove the rights of the new employee?
Who is Participating?
KimputerConnect With a Mentor Commented:
Workgroup never mattered in Windows networking if you directly called the server by hostname (instead of browsing). As it worked before deleting the Everyone privilege, we can safely assume he already directly called the server by hostname.
John HurstConnect With a Mentor Business Consultant (Owner)Commented:
I suggest you enumerate the users of the "other" computers as users on the Windows 7 "server" machine. Particularly do this for the Vista machine. Then you can provide security to folders by user name.

Also make sure the Advanced Network Sharing settings (File and Print, Network Discovery and NO Homegroup) have all been set properly.

See my article on Folder Sharing for Modern Machines.
RSchiererAuthor Commented:
thank you John for your response. I did ensure that Advanced Network Sharing settings were all 'ON'. But I am not sure about the status of which 'group' ie HOME they are configured for. I will definitely take a look at your article and get back to you on how I made out.
Train for your Pen Testing Engineer Certification

Enroll today in this bundle of courses to gain experience in the logistics of pen testing, Linux fundamentals, vulnerability assessments, detecting live systems, and more! This series, valued at $3,000, is free for Premium members, Team Accounts, and Qualified Experts.

KimputerConnect With a Mentor Commented:
Are you sure the Vista is logging in properly to the Win7 files "server" ? I really hope this Win7 is the Professional version, instead of the Home / Home Premium version ?
Check the user by having the Vista connect to the Win7 server, then on the Win7 server > Start > Run > compmgmt.msc > browse to System Tools > Shared Folders > Sessions > You will see the user from the VIsta PC (either by hostname or IP number). If it's NOT the user you'd expect, the Vista is connecting as the wrong user (go to the VIsta, then Control Panel > Users > saved Windows credentialsfor that user, change it to the user you want)
Just a silly point. They are all members of the same workgroup?

John HurstBusiness Consultant (Owner)Commented:
@RSchierer  - Thanks, and I was happy to assist you.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.