Word press Landing page showing additional components

I am trying to create an ad campaign in face book for signup since I created a new landing page with visual composer.

I created a test landing page: http://www.romancewingman.com/main1/

Facebook shortens the link to: www.romancewingman.com/main1/

Which produces a different page. At the bottom of the second link an additional sign up form appears. This sign up form does not appear in the preview mode when I build it in word press so I am not sure why it's appearing.

Any ideas. Is the issue with the plugin? Facebook? Word Press?
SanjeetAsked:
Who is Participating?
 
Edmund FongFreelancerCommented:
Some encryption (or lack of it) issue causing it not to show up in the https address?

Try Google :)
https://www.google.com.sg/search?q=why+form+not+showing+up+in+https&ie=utf-8&oe=utf-8&gws_rd=cr&ei=wsyKVI_2B8G8uASUyIHoBQ

Seemed to be a common problem .. 248 million search results!!
0
 
Jason C. LevineNo oneCommented:
Both links above show me a page with two forms on it.  Perhaps you are seeing a caching issue?
0
 
SanjeetAuthor Commented:
TRy:

https://www.romancewingman.com/main1/

The 2nd form does not appear on this one.
0
 
Jason C. LevineNo oneCommented:
Erm, no.

Two forms...
0
 
SanjeetAuthor Commented:
This is what I see.

Landing-Page-Additional-Form.JPG
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.