Solved

iPad, iPhone, (iOS 8) not syncing Exchange Inbox anymore

Posted on 2014-12-08
13
3,425 Views
Last Modified: 2015-10-12
Hi folks,

My Exchange mailbox has suddenly and inexplicably stopped syncing new emails on my iPhone 5 and my iPad mini with Retina since last Tuesday.

I am not getting any visible errors on my iOS devices that would indicate that sync is failing or an error has occurred. Its seems like only the Inbox (sub-folders are unaffected) is not showing me emails newer than approx 2pm last Tuesday. I can view all the emails in other folders in this mailbox, including items newer than Tuesday and I can still send emails from this mailbox.

Both devices are on iOS 8 .1.1.

Outlook 2013 on my Windows 8.1 desktop is still functioning perfectly, as is Apple Mail on my Yosemite 10.10.1 Macbook Pro. I have also test the same mailbox on a Samsung Galaxy S4 running 4.4.2 which is NOT exhibiting the same behaviour, it too works fine. =(

We are running Exchange 2010 SP3 update roll-up 7 on Windows 2008 R2 x64 Std edition.

I have checked the logs for anything obvious and haven't found anything.

I have tried deleting the mobile devices associated with my mailbox in EMC and resetting up my account on my iOS devices one at a time but it has not made any difference.  I still can only sync my inbox up to about 2pm last Tuesday.

I have tried deleting emails with large attachments too but that also has not helped.

I am running out of ideas and cant find any errors in the event log that are helpful. That's not to say there are none. Just that I can't find them. ;)

I would really appreciate any advice anyone has on this. If I have left out any detail please ask and I will answer them ASAP.

Thanks in advance,
Andrew
0
Comment
Question by:defecta
13 Comments
 

Author Comment

by:defecta
ID: 40488133
I have also tested my account on testexchangeconnectivity.com with 'sync inbox' checked and it too hasn't reported any issues.
0
 
LVL 18

Expert Comment

by:suriyaehnop
ID: 40488155
If you did test on another phone and it working fine, then delete the Activesync account on your Iphone and re-create it.
0
 

Author Comment

by:defecta
ID: 40488157
I have tested my account on an Android Phone and its working fine, but not on another iPhone or iPad.

You say delete the Activesync account from my iPhone. As mentioned in my OP I have deleted the Exchange account from my phone many times as well as the my mobile device connected to my mailbox in Exchange Management Console without success. I don't know of any other way to delete and Activesync account from my iPhone.
0
 
LVL 18

Expert Comment

by:suriyaehnop
ID: 40488161
When you try to create a new activesync on iphone what error appear? Do you try to use another mailbox instead of yours

Do you have a iphone device which is running lower OS version say 7.0?

Any issue related to Iphone and Exchange Activesync.

https://support.microsoft.com/kb/2563324/en-us/?wa=wsignin1.0
0
 
LVL 78

Expert Comment

by:David Johnson, CD, MVP
ID: 40488214
I had the similar issue, iPhone 5s setup Exchange ActiveSync on iOS 7.1.2; we tie specific iPhone device id's to each user on Exchange to stop them from setting up multiple devices which are outside of our control.  On iOS7 the device id recognized by exchange was the serial number of the device prefixed by "appl" it seems this is not the case on iOS8.

Scenario 1
iPhone 5S, iOS 7.1.2, Configured for Exchange ActiveSync, device id added to Exchange as appl******* - ActiveSync Email Works.
Upgrade to iOS 8 - ActiveSync Email Works
Upgrade to iOS 8.0.2 - ActiveSync Email Works

Scenario 2
iPhone 5S, iOS 8.0, Configured for Exchange ActiveSync, device id added to Exchange as appl*******  as per scenario 1 - ActiveSync Email doesn't work
It looks like everything is working, all tests pass successfully HOWEVER within Settings, Mail,Contacts and Calendars, Exchange (or whatever your ActiveSync profile is called), Automatic Reply shows Loading and no mail is received on the device.
Had a look on the Exchange server and there lots of Event ID 1019 MSExchange ActiveSync Warnings.  A blocked device of user [yourdomain\username], device id = ************************** (26 digit ID) is attempting to synchronize with Exchange ActiveSync.
Made a note of this 26 digit ID (which incidently you can also get when you setup the ActiveSync profile manually, it shows at the bottom of the screen "Exchange Device ID")  This doesn't help if you are using a MDM platform and automatically deploy the ActiveSync profile, not quite sure how you are meant to find this info from, maybe the error logs on the exchange server?.

Run up a powershell command prompt on Exchange server
Set-CasMailbox username -ActiveSyncAllowedDeviceIDs ************************** (26 digit id from above)
Give it 2 minutes
Automatic Reply shows as off on iPhone and mail starts synchronizing.

If I run up Exchange powershell and run the command
get-activesyncdevicestatisitics -mailbox username
against my working user in scenario 1 I see his DeviceID is still being recognized as Appl************ (12 digits)
If I run the same command for user in Scenario 2 I see his DeviceID being recognized as ************************* (26 digit address) not the Appl address from Scenario 1
So in short if you are restricting access to Exchange ActiveSync via DeviceID the format appears to have changed between iOS7 and iOS8.  Activesync users who upgraded from iOS7 to iOS8 continue to work under the old device id format of appl********, however any of my new users I setup on iOS8 must have the 26 digit device id loaded into exchange or ActiveSync will not work.

http://bit.ly/1D1N0zU
0
 

Author Comment

by:defecta
ID: 40488220
I don't get any errors when creating the account or when checking mail. I have just tried another mailbox other than mine on my phone and it works fine.

I do have an iPhone 4 on iOS 7 which I *think* i have tried and had the same issue but I don't have it handy to double check to make sure I'm not getting confused.

Its looking more and more like there is something wrong with my mailbox when its paired with iOS.
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 18

Expert Comment

by:suriyaehnop
ID: 40488222
So far what we know are:

1. Used your mailbox and setup on Samsung phone - work
2. Use another mailbox and setup on your Iphone - work.

Try this way, log on to OWA, remove all exisiting activesync phone. On the Iphone, also remove activesync account, then create activesync on you iphone again.
0
 

Author Comment

by:defecta
ID: 40488224
David, neither Scenario 1 or 2 describe my issue.

 I have been using my Exchange mailbox happily on 8.1.1 for some time until i noticed new emails stopped coming through last Tuesday.

I am not getting the Event ID 1019 warnings in the event log at all
0
 

Author Comment

by:defecta
ID: 40488234
suriyaehnop, If I am understanding what you are describing, i have already tried that many times and it has not worked.

I have not removed activesync devices through OWA though. I have done it via EMC instead.
0
 
LVL 18

Expert Comment

by:suriyaehnop
ID: 40488247
Then let try to delete all existing exchange activesync parthership in OWA and then re-create the account on iphone again.
0
 

Accepted Solution

by:
defecta earned 0 total points
ID: 40489939
So in what feels to me like a hollow victory, my iPhone inexplicably started to sync mail this morning.

After my last post on here yesterday, my mailbox was repeatedly sending calendar invites to a meeting that was rescheduled last week without any intervention on my part. I put it down to my Macbook being on and my trying to reschedule the meeting on my Macbook Calendar app rather than Outlook.

So I removed my mailbox from every Apple device I own, deleted the activesync partnerships and tried again. Same problem still. So I gave up for the night.

Then this morning I check my Exchange mailbox on my phone on and my emails suddenly start flowing through. (??)

So I dont have a 'smoking gun' but my problem is solved. I am putting it down to my Macbook for now as everything else i have done many times before without any success.
0
 

Author Closing Comment

by:defecta
ID: 40498714
I cant say exactly why it started working but the one thing that I did to fix it that I had not already done before, that no one else had suggested, was remove Exchange from my Macbook.

Thanks for your suggestions fellas.

Cheers,
AC
0
 

Expert Comment

by:Jose
ID: 41035836
Hi
I had all these problems on my iPhone 6,6s and iPad iOS 9x
Having tried everything ....
The solution that finally worked for me:
- Delete the exchange account on iOS
- Reset network settings
- Registration of the account on iOS with 3G / 4G
- Use for the use name (user logon name  pre-windows 2000) : my_domain\my_name
Not for use with .local or other extension of country.

sorry for my English
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now