Solved

Access 2010 mdb (2003 file format) corrupts on 2008R2 Virtual Server ESXI 5.5

Posted on 2014-12-09
18
309 Views
Last Modified: 2016-02-11
We migrated from a physical environment to all Virtual environment (ESXi 5.5) on HP C7000 Chassis with HP Virtual Connect, BL460c Gen 8 Blades direct connected to a 3PAR 7200 SAN last month.  Since we have migrated all of our Access 2010 mdb (and mde) database are constantly getting corrupted.  We have to get the users out and Compact/Repair sometimes 6 times a day for each of 7 production databases.  

I have one mdb that runs nightly vba code and emails out reports at 2am that has never had a corruption problem until now.  It only has 1 user and most of the linked tables are SQL Server tables.  It does however create numerous temp tables for reporting purposes.  This morning during the scheduled script, the database became unrecognizable, I did a compact / repair and then I noticed that one of the tables was completely missing!  had to restore from a backup.

We have opened tickets with Microsoft, HP Blades, HP Virtual Connect, 3Par all to no avail.

Anyone else having problems with corruption of Access mdb and mde files running on VMware ESXi 5.5?
0
Comment
Question by:BFanguy
  • 11
  • 4
  • 3
18 Comments
 
LVL 119

Assisted Solution

by:Andrew Hancock (VMware vExpert / EE MVE^2)
Andrew Hancock (VMware vExpert / EE MVE^2) earned 100 total points
ID: 40488938
Make sure ALL your VMs are using the VMXNET3 interface, and not the E1000 interface.
0
 

Author Comment

by:BFanguy
ID: 40488990
Andrew,
All the VM's are using the VMXNET3 interface.

When I am in one of the access database linking tables to SQL Server of making form changes from either my physical laptop or a 2008R2 Remote Desktop Server, I experience 30-50 second pauses all day long.    Our Virtual Environment is way under utilized so I do not believe it is a performance issue, but I know access does not like network interruptions.  We are using Symantec EndPoint Protection 12.1.5 on the 2012R2 File Server, but I have put in exceptions on the folder where the access databases are stored.
0
 
LVL 119
ID: 40489135
is this a network issue?

SAN issue ?

performance issue ?

have you done any vmxnet3 tuning ?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:BFanguy
ID: 40489156
We could not find any problems with the blades or the san (no logs) with the assistance of HP.  The virtual Connect support group was no help either (no errors in the logs).  I have a 3rd party troubleshooting these "pauses" for the past week, nothing they can pinpoint.

Have not done any vmxnet3 tuning,  can you be more specific?
0
 
LVL 57

Assisted Solution

by:Jim Dettman (Microsoft MVP/ EE MVE)
Jim Dettman (Microsoft MVP/ EE MVE) earned 400 total points
ID: 40489163
<<is this a network issue?

SAN issue ?>>

 On these points, are the DB files local to MSACCESS.EXE (instance of Access running) or remote?

 If remote, then I would try to make them local and see if the problem disappears (at least with the one DB that runs nightly).  If it's not remote and running locally, then it's something other than network.

 My guess though would be that it's the SAN.   Access itself runs fine under VM's, but there are issues with various OS's and older versions.  2010 though should be fine.

 Other questions are:

1. Were you running under 2008R2 previously or another OS?

2. Did you change from a 32 to 64 bit OS?

Jim.
0
 

Author Comment

by:BFanguy
ID: 40489180
Andrew,  I found an article on Best practices for Performance tuning of latency sensitive workloads in vmshpere vm's.
will apply the settings from the paper.

Jim,  all of the access databases reside on a 2012R2 vm file server, but they were migrated from a physical 2008R2 server to a 2008R2 VM server and then to a 2012R2 VM (we hoped moving to 2012R2 would fix our corruption problem).

We are running 32bit version of access 2010  (no change)

I like the idea of moving the "Nightly" database locally, but the server that i would be moving it to is also a VM and all of my physical server blades are SAN boots.  Still worth a try.

The other production Access database have to be stored on a File server, because they are accessed from Desktops and 5 different 2008R2 Remote Desktop Servers VMs.
0
 

Author Comment

by:BFanguy
ID: 40507046
I have tried all of the Best practices for Performance tuning.  No change.

I moved the mde files to the local drives of all of my remote desktop servers and we have not had a corrupt mde file since.  This leads me to believe it is a network issue and not a san issue (the remoted desktop servers are virtual and their drives are stored on the SAN.

I do not like having the  mde files on the C Drives of each RDS but for now i can at least take a day off.

Any suggestions on what i should try now that i have concluded it's a Virual Network issue?
0
 
LVL 57

Assisted Solution

by:Jim Dettman (Microsoft MVP/ EE MVE)
Jim Dettman (Microsoft MVP/ EE MVE) earned 400 total points
ID: 40507300
Well some progress anyway....you've narrowed things down a bit.   Andrew is THE VMWare expert, so I'll let him comment on the networking.

I will add though that in general with networking, I:

1. Make sure drivers are updated.
2. No diagnostic protocol's are enabled on the adapter (they sometimes will disconnect the adapter from the media, test, then reconnect, which drives JET nuts).
3. No advanced power features are enabled on the adapter (again, will drive JET nuts).
4. If a 1GB connection, fix the speed at 100mbps for a test to try and eliminate cable problems.
5. Test the cable if possible.
6. Monitor for fragmented and dropped packets.  First is tuning, second is a sign of network connection.

 JET overall is very sensitive to network timeouts and latency.   More so than anything else.   it will complain long before other apps will.

Jim.
0
 
LVL 119
ID: 40507322
Is you network performance in the VM, slow  or appear slow?

Was the network interface tuning, applied in the VM ?
0
 

Author Comment

by:BFanguy
ID: 40507334
The remote desktop servers will pause (lock up) for 20-30 seconds for no reason.  This is what usually causes the corruption.

The tuning was done at the host level.
0
 
LVL 119
ID: 40507361
So, you've not adjusted any VM OS parameters, e.g. TCP offload etc

I'll get some links...for you to follow.
0
 

Assisted Solution

by:BFanguy
BFanguy earned 0 total points
ID: 40510085
Yes,  i had done this about a month ago:

C:\Windows>netsh int tcp show global

TCP Global Parameters
----------------------------------------------
Receive-Side Scaling State          : disabled
Chimney Offload State               : disabled
NetDMA State                        : enabled
Direct Cache Acess (DCA)            : disabled
Receive Window Auto-Tuning Level    : disabled
Add-On Congestion Control Provider  : ctcp
ECN Capability                      : disabled
RFC 1323 Timestamps                 : disabled


C:\Windows>netsh int tcp show heuristics
TCP Window Scaling heuristics Parameters
----------------------------------------------
Window Scaling heuristics         : disabled
Qualifying Destination Threshold  : 3
Profile type unknown              : normal
Profile type public               : normal
Profile type private              : normal
Profile type domain               : normal

Do these look correct?
0
 

Author Comment

by:BFanguy
ID: 40510094
above is what i get from the command prompt, however, if i look at the advanced tab of the adapter i see the following:
IPv4 Checksum Offload - Rx & Tx Enabled
IPv4 TSO Offload - Enabled
Large Send Offload V2 (IPv4) - Enabled
Offload IP Options - Enabled
Offload tagged traffic - enabled
Offload TCP options - Enabled
TCP Checksum Offload (IPv4) - Rx & Tx Enabled
UPD Checksum Offload (IPv4) - Rx & Tx Enabled

not sure why they show as different.
0
 

Author Comment

by:BFanguy
ID: 40538154
any help would be appreciated
0
 

Accepted Solution

by:
BFanguy earned 0 total points
ID: 40538507
I can add that moving the mdb files to the local 2008R2 Remote desktop server did fix the problem, but I would rather run them form a central file server.  i.e.  it is definitely a Network Setting, whether it be at the VM level or the operating system level.
0
 
LVL 57
ID: 40538660
Thanks for posting back again.

Jim.
0
 

Author Comment

by:BFanguy
ID: 40570680
Andrew,  I was hoping for those links.
0
 

Author Closing Comment

by:BFanguy
ID: 40756821
Removed all local tables to sql, moved .mde files to local drives on 208R2 virtual servers.

Combination of numerous items, found a workaround, not what we really wanted to do.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I will show you HOW TO: Install VMware Tools for Windows on a VMware Windows virtual machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, using the VMware Host Client. The virtual machine has Windows Server 2016 instal…
Phishing attempts can come in all forms, shapes and sizes. No matter how familiar you think you are with them, always remember to take extra precaution when opening an email with attachments or links.
In Microsoft Access, learn how to use Dlookup and other domain aggregate functions and one method of specifying a string value within a string. Specify the first argument, which is the expression to be returned: Specify the second argument, which …
With Microsoft Access, learn how to start a database in different ways and produce different start-up actions allowing you to use a single database to perform multiple tasks. Specify a start-up form through options: Specify an Autoexec macro: Us…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question