Link to home
Start Free TrialLog in
Avatar of Neil Russell
Neil RussellFlag for United Kingdom of Great Britain and Northern Ireland

asked on

IIS rewrite from an IIS web site to a site on a SharePoint server.

Hi, we have an old .NET application running on IIS 7 that has been redeveloped in Sharepoint.  
The issue I am having problems with is all the OLD links and favourites that people have lay around.  We can just switch off and break them so need to find some way of redirecting to the same source document but in SharePoint.

For example:
OLD LINK -  http://dontknowhow.domain.com/documents/PatientLeaflets/insulin%20adjustment%20guidelines%20-%20basal%20bolus%20rapid%20acting%20analogue.pdf

We need it to be redirected BY IIS7 on dontknowhow.domain.com  to
NEW LINK - http://sharepoint.domain.com/Documents/insulin%20adjustment%20guidelines%20-%20basal%20bolus%20rapid%20acting%20analogue.pdf

The BOLD bit is the actual document name and stays the same.

The old link could start with ANY of :-
http://dontknowhow.domain.com/documents/PatientLeaflets
http://dontknowhow.domain.com/documents/Documents
http://dontknowhow.domain.com/documents/Policies

The new link will always start with:-
http://sharepoint.domain.com/Documents  followed by the document name.

Any ideas on how this could be achieved?

Regards,

Neil
Avatar of Mohit Nair
Mohit Nair
Flag of India image

Try adding an entry in IIS > IIS redirect. There you would find an option to put the old url and redirect to url.
Avatar of Neil Russell

ASKER

Well ok given the above, can you explain how that is achieved?
Add a redirect is hardly an answer to a question that explain in depth exactly what needs to be achieved.
ASKER CERTIFIED SOLUTION
Avatar of Ray
Ray
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Regardless of how I do the rule It seems to be ignored and I get a 404 error for ANY url starting with

  http://dontknowhow.domain.com/documents/Policies/
With a little work I finally have a working redirect now :D

Cheers