Microsoft rdp client for MAC

Recently upgraded to new PCs with Windows 8.1.  Have been using the Microsoft RDP Client for MAC for years.  Connecting directly to individual PCs with unique port numbers.  Now getting the error: Remote Desktop Connection cannot verify the identify of the computer that you want to connect to.  This is on the MAC client side.  One is OSX 10.5 the other is 10.7 with same results.
Windows 8.1 PCs are in a domain environment with a 2012 Essentials server.  Can connect to all the Win 7 PCs in the same domain.
smowenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strungCommented:
Try the free CoRD RDP client for Mac instead and see if that solves the problem:
http://cord.sourceforge.net
0
strungCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
strungCommented:
This link http://kb.mit.edu/confluence/display/istcontrib/Establishing+an+RDP+connection+with+a+Windows+8.1+client+from+Mac+OS+X  suggests the following solution:

Enable RDP security layer in Group Policy on the Win 8.1 machine:

1. Verify that the firewall allows remote desktop connections with RDP (Port 3389)
2. Click Start>Run
3. Type gpedit.msc and click "OK"
       Result: The Group Policy Editor will open
4. In the left hand side bar, expand Computer Configuration>Administrative Templates>Windows Components>Remote Desktop Services>Remote Desktop Session Host
5. Select "Security"
6. Change "Require use of specific security layer for remote desktop (RDP) connection" to Enabled" and select "RDP" in the Options pane.
7. Change "Require user authentication for remote connections by using Network Level Authentication" to "Disabled."
8. Close Group Policy Editor and reboot the machine for changes to take effect.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

smowenAuthor Commented:
Thanks for all the quick replies.
I will try the Group Policy method.  I failed to mention that connection is good from Windows PCs meaning that the port number and firewall is configured correctly at router and on Win 8.1 PC.
Will keep you posted...
0
serialbandCommented:
The latest "Microsoft Remote Desktop" client for Apple is currently only in the App store.  It's free from Microsoft and should solve your problems with connecting to Windows 8.1 and Server 2012.  CoRD will also generate errors until you "fix" or configure Windows 8 and Server 2012 to reduce the added "security" checks.  The new Microsoft client lets you keep the additional security checks.
0
smowenAuthor Commented:
Thanks for all the help.  I did make the group policy changes last week to no avail.  Just this morning I finally got them to bring their MAC laptops in.  I installed CoRD, configured and it works.  Everybody happy...
Thanks again and happy holidays!
0
smowenAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for smowen's comment #a40507473

for the following reason:

Making the Group Policy change and using the CoRD RDP client solved the user's access issues from MACs.
0
strungCommented:
I think my correct answer should be marked as the solution.
0
serialbandCommented:
I agree with strung there.  He made the suggestions that you implemented.  CoRD probably also worked after some of those group policy changes too.

The newer Microsoft Remote Desktop from the App Store wouldn't have required those group policy changes.
0
strungCommented:
Points should have been awarded for the correct answer.
0
strungCommented:
I also suggested CoRD in an earlier post in this thread.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.