Watchguard and Access Control Allow Origin

Our media department here uses an external service for streaming that includes live comments. However, when the live feed is running they have to manually refresh the browser to see that chat updates (and refreshing causes the hit count to go up therefore meaning we don't get an accurate count of people viewing the session). This does not occur if a user is not behind our firewall.
I've contacted the streaming host and they said to make sure one website was allowed (pubnub) and that's all that should be necessary but that didn't fix it. They then said I may need to "allow"  Access Control Allow Origin in the header fields in the appropriate policy. I went there and have no idea how to implement it. Is this the path I should be taking? They aren't familiar with Watchguard products.

I have an XTM510 running 11.8 and WSM 9

Thanks for any input you may have.
Who is Participating?
btanConnect With a Mentor Exec ConsultantCommented:
WG by default will block e.g. removes HTTP headers it considers dangerous, including Access-Control-Allow-Origin

You may want to check out the pdf. Specifically is to under HTTP-proxy policy> Proxy Action > HTTP Response > Header Fields, to add "Access-Control-Allow-Origin:*" into it. Note that header fields not in the list are stripped by default.
(see "HTTP Response - General Settings" section)

there is another EE reference that may be useful in configuring an HTTP-Server Proxy Action (though not specific to this use case) -
perkwerxAuthor Commented:
Thanks for the information. Now I just need to decide if it's worth allowing (and I'm leaning to the "no" side).
Thank you!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.