WSUS Client - Windows could not search for new updates.

My WSUS server has been broken for a while. I currently have it configured through group policy.

On client computers, windows update tells me "Windows could not search for new updates" Code 80072F8F

Every computer on my domain runs into this issue. I installed a diagnostic tool and it told me this:

# Solarwinds® Diagnostic Tool for the WSUS Agent
# 12/8/2014
Machine state
  User rights:                                       User has administrator rights
  Update service status:                             Running
  Background Intelligent Transfer service status:    Running
  OS Version:                                        Windows 7 Professional  Service Pack 1
  Windows update agent version:                      7.6.7600.320 (WU Agent is OK)
Windows Update Agent configuration settings
  Automatic Update:                                  Enabled
  Options:                                           Notify before download and installation
  Use WSUS Server:                                   Enabled
  Windows Update Server:                             https://myservername
  Windows Update Status Server:                      https://myservername
  WSUS URLs are identical:                           Identical
  WSUS URL is valid:                                 Valid URL
WSUS Server Connectivity -- The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.
  clientwebservice/client.asmx:                      Error: TrustFailure
  simpleauthwebservice/simpleauth.asmx:              Error: TrustFailure
  content:                                           Error: TrustFailure
  selfupdate/                            Error: TrustFailure                                       Error: TrustFailure

How can I resolve?
Who is Participating?
Seth SimmonsConnect With a Mentor Sr. Systems AdministratorCommented:
if your wsus server is on 2012, the default port is 8530; 8531 with SSL
if you are using SSL (as it appears in the output) then your server definition in your GPO should be https://servername:8531
ScubberAuthor Commented:
Well, that did it. So simple, thanks
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.