My Windows 7 Taskbar -- and Google Desktop -- are behaving differently now

OK, I like having my Windows 7 Taskbar always on top.  This way, even when I have other program windows maximized, I can see small thumbnail images of all open windows in all open programs.  (I can even pause and stop media players without restoring or maximizing the windows -- very nice!)  Also, my Google Desktop is always available, "hidden" behind the right side of my monitor, but ready to pop out when the mouse passes over the right side of the screen.  

Lately (after installing something or something updated, no doubt), the Taskbar is behaving differently, and so is Google Desktop.  The Windows Taskbar is still "on top" at the bottom of my screen, but when I pass the mouse over the open program icons, I no longer see the thumbnails of open windows (although it sometimes appears that they are there behind the front window), and after a second or two, I sometimes see the tooltip text balloon appear over the area where the thumbnail would have been.  I can click on the Taskbar and give it the focus so then it's on top, and it works like it should, but I didn't have to do that before, and I don't want to have to do that every time I need it.

At the same time the Windows Taskbar stopped working properly, so did Google Desktop.  It is no longer always available "behind" the right side of my screen.  The mouse will no longer bring out the sidebar like it used to, but instead, I have to bring up some other aspect of the program, like "add gadgets" or "about" and then it becomes available on the side of the screen.  This is very inconvenient.

I have already tried adjusting the "auto hide" feature of the taskbar, and that is not the solution.  I never used "auto hide" before, but the very first thing I tried to fix this issue was selecting and then deselecting it, but it made no difference.  The problem is still there.  

I'm thinking this is a bug, possibly a change in the registry or something, caused by some update or install.  Even though Microsoft has removed the "always on top" feature from the options menu of the Taskbar, I know the feature must still be there in the background somewhere.  

By the way, I have been using an Aero theme the entire time.

Hope the Experts here can help!
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

you can do a system restore to a date it was ok - then watch out for the updates!
You probably (accidentally) lost the "aero preview" feature...

Right click on an empty area of your desktop, select "personalize" and then select one of the aero themes to reset it back...
VegasDudeAuthor Commented:
I appreciate the efforts.

Resetting an Aero theme did nothing.  Thanks anyway, n2fc.

Nobus, I already thought about doing a System Restore, but something tells me this is a setting that can be controlled.  This is why I'm trying the Experts Exchange for the solution.  But if no one here knows how to control the Taskbar's behavior, I guess I'll have to seek a solution elsewhere.
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

WEIWhich video driver are you using?  Perhaps an update lowered its capability to below the threshold that is "Aero capable"...

Also, what is you WEI (Aero) score?... Even at a meager 4.4, I can use Aero here...
More things to check:

1) Do you use "Stardock?" if so, uninstall it... It turns off Aero!

2) Try the following troubleshooting:
This is a very simple task, if you are not sure if Aero is enabled, go to Action Center, click on troubleshooting, in the list you will see Appearance and Personalization, under that heading click on Run Display Aero Desktop Effects, problem solved.

3) Try the following registry fix:
Force Enable Aero in Windows 7
1. Click on Start and type regedit at run
2. Now Navigate to the following registry key:
3. In the right details pane, create following Three DWORD (32-bit value) entry
UseMachineCheck, and set its value to 0.
Blur, and set its value to 0.
Animations, and set its value to 0.
4. Close Regedit
5. Click on Start and type CMD with administrative Priviliges
6. Now type following command(s)
Net Stop uxsms
Net Start uxsms
Above command will stop and start Desktop Window Manager Session Manager.
7. Now you can turn on Aero by right clicking on desktop-> Personalize -> Select Windows Colors
VegasDudeAuthor Commented:

First, my Windows Experience Index is 5.6, which is also the Graphics subscore.  The graphics card is an AMD Radeon HD 6530D.  I have a hard time believing that my hardware is the issue, since the behavior we're talking about is based on whether the taskbar has the focus or not, instead of it being always on top, where the focus did not matter.

And before I start making changes to the registry, just answer this: if I can see "through" the windows just like I have always been able to do, then Aero is on, correct?  Your posts are entirely about "enabling" Aero.  Aero still looks the same.  When the taskbar has the focus, I can see "behind" the "translucent" areas of the thumbnails just like I always have.  My windows have not suddenly become opaque, where I cannot see behind them at all.  As I stated in my original post, I am using Aero themes, and if there was anything odd about the way Aero looked or performed, I would have included that in my post.

The problem is the "always on top" feature of the taskbar having changed slightly.  Even when it's still visible at the bottom of the screen when other windows are maximized, I no longer can see the thumbnails of other program windows without clicking on the taskbar to give it the focus.  I didn't have to do that before this issue popped up, and now I do.  And the Google Desktop sidebar seems to have followed suit.

I would really prefer to not have to go to all the trouble to restore my computer to a previous point.  Isn't there ANYONE who knows what to adjust to keep the taskbar on top???
Microsoft released a Windows update in December that broke a bunch of things in Windows 7, notably video drivers for AMD, among other things. Microsoft has released a new update to fix the old update. If you re-check for Windows updates and install, you should be okay.

Install KB3024777 to fix an issue with KB3004394 on Windows 7 and Windows Server 2008 R2
I have never used Google Desktop but use Object Dock
with Dexclock
It puts the wallpaper on my desktop with date and time. Lovely wallpaper to download all free uses no system resources.  see attached current wallpaper

Could be that your Google Desktop had an update or a fight with windows Aero for domination ;)
There is a small address bar at the bottom of the gadget and from the looks of it it sits just above the Show desktop /Peek at desktop Maybe you accidently touched the peek bar and disabled it?
Google desktop gadgetshow desktop
Google Desktop is a discontinued computer program with desktop search capabilities,
In September 2011, Google announced it would discontinue a number of its products, including Google Desktop.
Another trick I use is to hold down the windows logo key while tapping the tab key, all open windows will fly up and each tap of the tab key while holding down the logo key scrolls them release on the window you want
VegasDudeAuthor Commented:
Well, I decided to uninstall RealPlayer Cloud, one of the programs which was installed right before the taskbar started behaving strangely.  The other was the new version of Skype.  I chose to uninstall RealPlayer Cloud instead of the new Skype because RealPlayer Cloud put this "button" at the top of the screen that had an "auto-hide" feature just like the taskbar.  I figured that button may have forced its way in front of the taskbar when it was installed.  It was a good guess, because uninstalling RealPlayer Cloud did return my taskbar to its previous state!

I sent a message to the support staff at RealPlayer Cloud letting them know how disappointed I was that they would send out software that contained this bug without having tested it first.

I still would have liked to find the way to keep the taskbar on top in Windows without having to do a system restore, or uninstall other programs, if indeed it is possible with the way those programs install themselves.

To the experts who tried to help me: Thanks anyway!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Well done VegasDude , but have you checked if it is also related to Google Desktop?
Is this only when you had Real Player Cloud active running and by hiding it while active it then disabled the taskbar
Many thanks for sharing your solution.
VegasDudeAuthor Commented:
I'm not sure what you mean by "related" but my Google Desktop app also returned to its correct behavior, which was to "auto-hide" but always be available with the mouse passing over the right side of the desktop.  That way, I can use Windows sidebar gadgets, which always remain visible, in conjunction with Google Desktop gadgets that remain "hidden" from view but quickly available.  (Google Desktop still has a gadget or two that are not included with Windows sidebar gadgets.)

The thing I used most from Real Player was the downloader.  It's very convenient to download a video by the click of a button.  But they changed it to that other "button" or "bar" that would always be there on the top center of the screen, and would become fully visible if you moved the mouse over it.  Another thing I didn't like about that was that it would get in the way of new tabs as they were opened in the browser.  I much preferred the old "download this video" button that would appear with the previous version.

We'll see if they fix this, but I won't be re-installing any Real Player software for a while, as they have totally committed to this "cloud" thing.
Yes I hate all this Cloud Onedrive stuff as well
I use Chrome  go to settings then extensions get more extensions
I bought youtube downloader pro somethin like 20 bucks a year
which is a stand alone program outside of any browsers I just add the URL, the pro can be used to convert video of any types extract audio etc que them. Works great
 But occasionally  even YTD pro will not download some but will in FF using these two
Try using download helper extension with download youtube as mp4 add on which gives the download button below the download helper for video that are not supported in download helper
open FF and go here click on install
goes here, see the three coloured balls download helper click install
check your add ons listed in FF
With the other download youtube as mp4
Use FF and go here
Click on the green button add to Fire Fox
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.