Solved

GPOs won't run on 2012 R2 AD DC with DRP

Posted on 2014-12-09
10
143 Views
Last Modified: 2014-12-15
I have a very irritating problem where GPOs won't apply on my RDP users on AD DC with RDP server (TS).

There are two test policies, removal of Recycle Bin and one startup script with SUSBT command, but neither runs, and RSoP gives positive results for both.

Can anyone help?

Thanks.

UPDATE: I have tried enforcing the policies, and forced gpupdate, from admin account, but neither worked.
0
Comment
Question by:mrmut
  • 7
  • 2
10 Comments
 
LVL 19

Expert Comment

by:Miguel Angel Perez Muñoz
ID: 40490646
Removal of Recycle Bin is a user GPO, only fail on DC or on all computers? could you check your GPO link is on users container?
0
 
LVL 7

Expert Comment

by:Thomas Wheeler
ID: 40490648
What are the results of gpresult /v do you see the policies?  Are there event logs showing errors ?
0
 

Author Comment

by:mrmut
ID: 40490699
Everthing passwed without errors. Tried Win+R command, and it worked.

Will check errors and report back.
0
Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

 

Author Comment

by:mrmut
ID: 40490730
I see no errors i Applications log. Any other place to check?
0
 
LVL 7

Expert Comment

by:Thomas Wheeler
ID: 40490762
Did gpresult show your policies?
0
 

Author Comment

by:mrmut
ID: 40490774
Yes. As applied group policy objects.

I tried "shaking" the system (restart), and the Recycle bin and some other settings work fine now, however my startup command with subst doesn't seem to work. (I will go and check permissions now)
0
 

Author Comment

by:mrmut
ID: 40490785
Checked it - permissions are OK
0
 

Author Comment

by:mrmut
ID: 40490954
I tried using map network drive (hosted on the same machine), and that worked with no problems.
However, using map instead subs for local usage is bad performance wise.
0
 

Accepted Solution

by:
mrmut earned 0 total points
ID: 40492521
I solved it.

It seems that subst is not on the same permission elevation as the user, thus it is shown in another space, "invisible" to the user.

 I have ammended this by creating "permanent" registry subst by adding:

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\DOS Devices

Key:

Z:


Value:

\\??\\DRIVE:\\PATH\\PATH

It works.
0
 

Author Closing Comment

by:mrmut
ID: 40499986
This worked.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes my battle tested process for setting up delegation. I use this process anywhere that I need to setup delegation. In the article I will show how it applies to Active Directory
This article explains the steps required to use the default Photos screensaver to display branding/corporate images
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…
This video shows how to use Hyena, from SystemTools Software, to bulk import 100 user accounts from an external text file. View in 1080p for best video quality.

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question