Solved

vCenter Service fails to start

Posted on 2014-12-10
19
361 Views
Last Modified: 2014-12-14
Hello,

Is a fresh install and The installation process went OK till the port 80 was used by a SQL service. then all was running OK  till the first reboot withtwo services (Virtual Center & Management Webservice ) not starting with event ID:1724 & 7001. I try many option and reserch such this site http://terenceluk.blogspot.fr/2010/07/vcenter-virtual-center-service-fails-to.html but is still not working.

Thanks by advance for your help
0
Comment
Question by:CalvinGE
  • 10
  • 9
19 Comments
 
LVL 120
ID: 40491603
I would scratch the installation, and re-install, rather than trying to fix a failed new installation.
0
 

Author Comment

by:CalvinGE
ID: 40491612
Well, the fact I don't know the cause worriy me, how i can be sure it will not hapen again in the next reboot
0
 
LVL 120
ID: 40491747
Personally, I would not waste time.

Is you SQL Service starting up?

Is this a physical or virtual installation?

What is the OS ?

What version are you trying to install ?

Local SQL or Remote ?
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 

Author Comment

by:CalvinGE
ID: 40491765
Yes, all SQL services  is running OK and is hosed to a virtual 2012 Server on ESX 5.5 server
0
 

Author Comment

by:CalvinGE
ID: 40491796
Hello,

I have added the log file, it seems there is an autentification problem
0
 

Author Comment

by:CalvinGE
ID: 40493520
OK, I have re-installed the vCenter only. (i don't loos the database entry). Then now I can start manually the two services VMware VirtualCenter Server and VMware VirtualCenter Management Webservices however impossible to start them automatically. I try to modify dependency to SQL, add a delay starting.....
0
 
LVL 120
ID: 40493560
Have you waited for the services to start?

It would appear, your SQL Service is running slow...

What computer and specification is this?

I would add Delays to vCenter Server Service starting.

Does SQL start automatically ?
0
 

Author Comment

by:CalvinGE
ID: 40493564
Yes SQL is starting OK, I said Yes because when I run both vCenter services all is running OK. the spec is 16 AMD opteron 6128 @ 2 GHz however I allowed only two processos for this virtaul machine and  8GB RAM.
0
 
LVL 120
ID: 40493628
have you tried the delay start of the vCenter Service ?
0
 

Author Comment

by:CalvinGE
ID: 40494122
Yes, i also  make recovery with 4 minutes, same problem
0
 
LVL 120
ID: 40494156
So, if you restart you server

1. vCenter Service and Web Management Services do not start although set to automatic ?
but SQL service is started

2. if you manually start them after wards, they start with no issue ?

So what event log error is provided ?
0
 

Author Comment

by:CalvinGE
ID: 40494191
OK, I found the error. By default those two services don't start this is sure. then to try to solve it I read this:  http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1007669  
According with this tread we need to add a depencies to MSSQL$SQLEXP_VIM, this is wrong for SQL 2014, the service name is MSSQLSERVER. now all is working OK
0
 
LVL 120
ID: 40494264
Is this 2014 Express or FULL ?
0
 

Author Comment

by:CalvinGE
ID: 40494268
Full
0
 
LVL 120
ID: 40494276
Maybe a bug with vCenter installer.
0
 

Author Comment

by:CalvinGE
ID: 40494290
Possible but the service name MSSQL$SQLEXP_VIM never exist then is impossible to add into the reg vpxd. I think vCenter is not tested yet to run with SQL2014. anyway, thx for your help, i close this as resolved
0
 
LVL 120

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 500 total points
ID: 40494328
Express is not supported yet, but Full version is supported, so should have been tested....

which version of vCenter though 5.5 U2 ?

I think you must be running an supported version of vCenter with SQL 2014 FULL!!!!

Only 5.5 U2 is supported on SQL 2014 FULL!

Get it patched, or you will have issues!!!

Always check the HCL, and vSphere Matrix before you install VMware software.
0
 

Author Comment

by:CalvinGE
ID: 40499343
vCenter is update tothe latest version and all is runnig fine, thy for your support
0
 
LVL 120
ID: 40499348
No problems, much better, being on 5.5 U2!
0

Featured Post

Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I will show you HOW TO: Suppress Configuration Issues and Warnings Alert displayed in Summary status for ESXi 6.5 after enabling SSH or ESXi Shell.
This article outlines why you need to choose a backup solution that protects your entire environment – including your VMware ESXi and Microsoft Hyper-V virtualization hosts – not just your virtual machines.
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …
This video shows you how easy it is to boot from ISO images for virtual machines with the ISO images stored on a local datastore on the ESXi host.

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question