vCenter Service fails to start

Hello,

Is a fresh install and The installation process went OK till the port 80 was used by a SQL service. then all was running OK  till the first reboot withtwo services (Virtual Center & Management Webservice ) not starting with event ID:1724 & 7001. I try many option and reserch such this site http://terenceluk.blogspot.fr/2010/07/vcenter-virtual-center-service-fails-to.html but is still not working.

Thanks by advance for your help
CalvinGEAsked:
Who is Participating?
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Express is not supported yet, but Full version is supported, so should have been tested....

which version of vCenter though 5.5 U2 ?

I think you must be running an supported version of vCenter with SQL 2014 FULL!!!!

Only 5.5 U2 is supported on SQL 2014 FULL!

Get it patched, or you will have issues!!!

Always check the HCL, and vSphere Matrix before you install VMware software.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I would scratch the installation, and re-install, rather than trying to fix a failed new installation.
0
 
CalvinGEAuthor Commented:
Well, the fact I don't know the cause worriy me, how i can be sure it will not hapen again in the next reboot
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Personally, I would not waste time.

Is you SQL Service starting up?

Is this a physical or virtual installation?

What is the OS ?

What version are you trying to install ?

Local SQL or Remote ?
0
 
CalvinGEAuthor Commented:
Yes, all SQL services  is running OK and is hosed to a virtual 2012 Server on ESX 5.5 server
0
 
CalvinGEAuthor Commented:
Hello,

I have added the log file, it seems there is an autentification problem
0
 
CalvinGEAuthor Commented:
OK, I have re-installed the vCenter only. (i don't loos the database entry). Then now I can start manually the two services VMware VirtualCenter Server and VMware VirtualCenter Management Webservices however impossible to start them automatically. I try to modify dependency to SQL, add a delay starting.....
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Have you waited for the services to start?

It would appear, your SQL Service is running slow...

What computer and specification is this?

I would add Delays to vCenter Server Service starting.

Does SQL start automatically ?
0
 
CalvinGEAuthor Commented:
Yes SQL is starting OK, I said Yes because when I run both vCenter services all is running OK. the spec is 16 AMD opteron 6128 @ 2 GHz however I allowed only two processos for this virtaul machine and  8GB RAM.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
have you tried the delay start of the vCenter Service ?
0
 
CalvinGEAuthor Commented:
Yes, i also  make recovery with 4 minutes, same problem
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
So, if you restart you server

1. vCenter Service and Web Management Services do not start although set to automatic ?
but SQL service is started

2. if you manually start them after wards, they start with no issue ?

So what event log error is provided ?
0
 
CalvinGEAuthor Commented:
OK, I found the error. By default those two services don't start this is sure. then to try to solve it I read this:  http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1007669  
According with this tread we need to add a depencies to MSSQL$SQLEXP_VIM, this is wrong for SQL 2014, the service name is MSSQLSERVER. now all is working OK
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Is this 2014 Express or FULL ?
0
 
CalvinGEAuthor Commented:
Full
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Maybe a bug with vCenter installer.
0
 
CalvinGEAuthor Commented:
Possible but the service name MSSQL$SQLEXP_VIM never exist then is impossible to add into the reg vpxd. I think vCenter is not tested yet to run with SQL2014. anyway, thx for your help, i close this as resolved
0
 
CalvinGEAuthor Commented:
vCenter is update tothe latest version and all is runnig fine, thy for your support
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
No problems, much better, being on 5.5 U2!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.