Cisco ASA PIX Multiple NAT Statements

I have a host on which I have IIS running and it therefore needs to be publicly accessible on TCP80/443.

I now also need this host to be accessible over an IPSec VPN tunnel, also on TCP80/443.

The remote end requires me to source NAT my host and I therefore need the following.

1. Host A NATs to public IP x.x.x.x under normal circumstances.
2. Host A NATs to private IP y.y.y.y only when passing traffic over the IPSec tunnel.

How do I configure this ?

I originally had a static NAT statement mapping host A to y.y.y.y. If I try to add a second NAT statement using an ACL which specifies host A and the remote subnets I get an overlap error.

If I remove both statements and enter the NAT statement with the ACL first followed by the statement mapping host A to y.y.y.y I get the same error.

How can I configure it to NAT to different IP addresses based on different destinations ?

TIA
ccfcfcAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

James HIT DirectorCommented:
OK. You definitely need to NAT from public to Host A, that's a given.
Why did you feel you needed to NAT the IPSec? As long as you enable Reverse routing, it will forward those packets out the same interface.  The ACL you configure as required but what happens to the remote network with the NAT statement removed? Is the tunnel configured to pass that traffic across? Can you show any logs?
0
ccfcfcAuthor Commented:
The remote side has imposed a subnet on us.

We need to NAT to addresses within this subnet that they have provided us for traffic going over the IPSec tunnel to meet with their addressing requirements, so I don't have the option of not doing this.

There isn't any logging to show yet as when I try to enter the second NAT statement I get the error message about an overlap.
0
Jan SpringerCommented:
You need to configure (nat exemption) an access-list and apply it to your NAT statement so that the IP addresses or subnets listed in the ACL are exempt from the NAT.

The configuration is different for 8.2 and earlier and 8.3 and later.
0
ccfcfcAuthor Commented:
NAT exemption is what I would normally be applying to traffic passing over an IPSec tunnel.

This isn't NAT exemption - the third party at the remote side is dictating the address that I need to NAT my side to. I cannot just NAT exempt it to use my private IP addresses - I have to NAT it to the addresses that I have been provided.
0
Jan SpringerCommented:
NAT rules are processed in order.  Can you place this rule above your current NAT rule?

nat (outside,outside) source static REMOTE_IP NEW_PUBLIC destination static NEW_PUBLIC CURRENT_PUBLIC

nat(outside,outside) source static CURRENT_PUBLIC NEW_PUBLIC destination static NEW_PUBLIC REMOTE_IP

or

nat(inside,outside) source status REMOTE_IP NEW_PUBLIC destination static NEW_PUBLIC INSIDE_IP

nat(outside,inside) source static INSIDE_IP NEW_PUBLIC destination static NEW_PUBLIC REMOTE_IP
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.