vcenter 5.5 vsphere web client empty

hello experts
i have a vcenter 5.5, i just convert a server onto it by incident wrong select version 10, so that i can't manage it via vsphere client, and it noticed i could only manage via vsphere web client, so i install vsphere web client server on the vcenter machine(win2k8 R2 x64).
after that i can login the vsphere web client, but everything in the inventory is empty, after google it i did rebuild the database following below link, but doesn't help, is there any thing i can do to fix this?

thank you

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2042200
beardog1113Asked:
Who is Participating?
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Okay you will need to re-install vCenter Server and all it's components.

e.g. SSO, Inventory, Web Client, and then vCenter Server.

it will use the existing database.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
What account did you use to login?

and did you grant permissions to your Active Directory users or Local Admin Accounts ?

Did you also know, that the latest vSphere Client 5.5 U2, can now manage Virtual Machines, which are version 10 and later.
0
 
beardog1113Author Commented:
hello
the vcenter is not integrated with Active Directory, and i am using administrator@vshpere.local to login, which is the default admin account while install the vcenter.

for vsphere client 5.5 U2, i have download and install it, version is 5.5.0 1993072, please confirm this is the correct version, while i try to manage a version 10 VM, a dialog pop up say i can't manage it like before, but once i click "OK", looks like i can manage the VM now, but with apply the change, an error dialog popup not understanding what it is, once go back review the changes are done, could you please confirm this is normal?

thank you
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
That is the issue, you need to login with the  administrator@vshpere.local, and then allocate permissions, add your vCenter Server and Hosts.

Specifying an Integrate with Active Directory, and assign permissions.

That is correct, newer features cannot be managed with vSphere Client 5.5 U2, but most features can.

The newer features do not even exist within the vSphere Client to be added, and these can only be added from the Web Client.

see this post, on how to setup your vCenter Server

http://blogs.vmware.com/smb/2014/02/back-basics-post-configuration-vcenter-5-5-install-web-client.html
0
 
beardog1113Author Commented:
hello Andrew
i will have my vcenter do not authenticate against with AD, and now looks like my vcenter web client service is have problem, in the inventory list, even "vcenter" number is 0, and looks like it is not because of the permission, so any ideas to fix this?

thanks
look this pls
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Okay, so no AD, so you add permissions to the Local Users on the server!
0
 
beardog1113Author Commented:
hi Andrew
are you mean add administrator@vsphere.local to windows server(vcenter) local?
administrator@vsphere.local is the vcenter user, how to do this?

thank you
0
 
beardog1113Author Commented:
hi Andrew
any ideas to make the vcenter web client to work in my scenario?

thank you
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
see here

http://blogs.vmware.com/smb/2014/02/back-basics-post-configuration-vcenter-5-5-install-web-client.html

you login with administrator@vsphere.local and then do the configuration.
0
 
beardog1113Author Commented:
hi Andrew
the problem is after i login vsphere web client, there is no "vcenter" in the inventory list, so i even could not configure it, see the screenshot in my previous post please.
thank you
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Okay, can you connect to vCenter Server using the older vSphere Client using the administrator@vsphere.local account ?
0
 
beardog1113Author Commented:
yes, administrator@vsphere.local could login via vsphere client without any issue.

thanks
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
and what do you see ?

any hosts ?
0
 
beardog1113Author Commented:
yes, with the hosts and VMS which managed under this vcenter server.

thanks
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Okay, to make this simpler, go to the root, e.g. the actual vcenter server at the top of the left hand pane, right click and Add Permission on the Right Hand Pane, or Tab.

Add Permissions in here to Local Computer Groups or Add Accounts.

 Then use these accounts to login to vSphere Client or Web Client, and you should then be able to see VM, Hosts, vCenter Server.
0
 
beardog1113Author Commented:
hi Andrew
i did try that, add a windows account as the administrator of vcenter, then same result:
login via vsphere client, i can see the inventory with hosts and VMs, but login via web, the inventory is empty.

thanks
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
How did the Datacenter and Hosts get added ?

I assume you have done all this before via the vSphere Client ?

because these are not added by default, a user has go to do this?

Did you install vCenter Server before, but didn't add the Web Client?

and just added the Web Client afterwards, I beginning to wonder, if your web client is not registered correctly ?

I also see an error message on your screen shot , which states, cannot connect to vCenter....

also see here

http://www.experts-exchange.com/Software/VMWare/Q_28297165.html

Are you using no standard ports for vCenter Server ?

see also here

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2050273
0
 
beardog1113Author Commented:
hi Andrew
the vcenter works well for several month already, and the beginning i did not install web client, until last week i need manage a version 10 machine, so i tried to install web client, and it doesn't work for me.
and i did not change any port from the default setting during the installation.
the link you paste from EE, there is not a final solution on this;
the line you paste from vmware, i did try that but doesn't help;
for you mentioned web client not registered correctly, any idea how to fix this?

thank you
0
 
beardog1113Author Commented:
not try that yet, i am give up to using the web client.
any way thank you very much
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.