Unable to add network printer

Hi

We have a client who connects to our ERP system to print orders off.  They connect via a site-to-site VPN and then access our system via an RDP connection to a Server 2008R2 instance.  Their printer is a HP LaserJet 4100tn

When I first set them up in the Spring I intended to use the Easy Print driver along with printer re-direction to print the orders.  However orders printed exceptionally slowly and I was not able to determine why.  Instead I set up their LaserJet as a local printer on our remote desktop server using a HP LaserJet 4100 Series PCL6 driver.  This worked perfectly and they have been printing without issue up until yesterday.

Yesterday for some reason the printer stopped working.  On our remote desktop server it appeared as greyed out with a exclamation mark on it.  I have done the following troubleshooting:

> They can print from their own local desktops to it
> They have turned it off and on again
> I can ping the printer from our server OK
> I can get onto the web interface of the printer OK from our server
> Restarting our RD server
> Turning the Windows firewall off on the RD Server

So I decided to remove the printer and re-add it.  I go thru the usual Windows printer setup wizard choosing to make a new TCP/IP port but when I put the IP address of the printer in Windows says it can't find the printer on the network (picture attached).

I have tried deleting the printer port that was associated with this printer and removing the driver but Windows still won't "see" the printer.

I am able to set this printer up on other RD Servers (2003 and 2008) and I also tried setting it up on an old XP box I had lying around without issue.  Oddly it only appears that this server is the only one that I cannot set it up on again even though it can ping the printer OK.

I did find a HP troubleshooting webpage here but that was no help and the software won't run on Server versions of Windows.

Not sure what to do next!
AddPrinterError.JPG
LVL 1
admincbfAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
admincbfConnect With a Mentor Author Commented:
This has been resolved by changing the IP address of the printer

After changing the IP address I was able to add the printer to the server OK.

I was not able to find out why this is the case but guessing there is some incorrect IP or port information stored in the registry.
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Hi

Have you tried to add any other printer from the network ?
is there any errors in the event log related to Print Spooler
0
 
admincbfAuthor Commented:
Hi

Thanks for your reply.  I am able to add other printers without issue.  There are no errors relating to the print spooler in the event logs.

Many thanks
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Are you able to ping the printer from the RD server?  Have you been able to add this printer on another RDS server?  My guess is that either printer IP configuration doesn't have default gateway defined.  With respect to the printing issues, have you tried deleting the user profile?  In RDP connecting properties, are you allowing printer mappings?
0
 
great_gentle_manCommented:
the image you attached shows you are on the right path, as you can ping the printer from your windows server 2008r2.

click on next button.

then in manufacturer frame select hp,

then scroll all the way down to hp laser jet 4100 pcl 6 driver.

and click next

give desired name and click finish to complete installation.


hp-4100-printer.jpg
0
 
admincbfAuthor Commented:
Thanks for your replies

Mohammed - as per my original post I can ping it etc.

Gentle Man - If I do this nothing comes out the printer when I print.
0
 
Rob GMicrosoft Systems EngineerCommented:
First!
Remove the printer again, delete the associated port, restart the spooler, check to see if it is gone.. if it looks gone.. stop the print spooler and check the registry..


Does the printer still exist in the registry?

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\printers
If you see the printer listed, delete the associated key.

Another location is:
HKEY_CURRENT_USER\Printers
However if it exists here, and deleting it from this location works, it's something you will want to script for all associated users, if not it will take you a while to go one by one to delete the associated printer.. Having it listed here shows some signs of profile corruption..


Once you have the registry cleaned out..
Reboot the server..
Try to re-install the printer and see if you get the error..
0
 
admincbfAuthor Commented:
Hi

Thanks for your reply.  I have removed the printer and also found one entry in either registry place you mentioned.  I have removed these entries and restarted the server but when I go to add the printer Windows is still not able to see it.

Many thanks
0
 
Rob GMicrosoft Systems EngineerCommented:
Admin,
Walk me through the steps you take to re-add it?
As in windows there are two different ways to do it..

I wanted to see if you have tried both ways?
0
 
admincbfAuthor Commented:
Start > Control Panel > Devices & Printers > Add a Printer > Add a Local Printer > Create New Port > Type of Port: Standard TCP/IP Port > Hostname or IP Address: 192.168.X.X > Port Name: Is IP Address > Next > Windows can't find the printer

Ta
0
 
Rob GMicrosoft Systems EngineerCommented:
Admin,
If you go here:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Standard TCP/IP Port\Ports\

Do you see the IP address listed?
drill down into it..
You should see a key called Port number, check the port (Default is 9100) but if you have multiple printers, it will likely be in a range.. 9100, 9101, 9102, etc.

If it exists, make a note of the port it was on..
Delete the folder under Ports

Launch a command prompt

In the command prompt attempt to telnet to the printer under port 9100, you may need to stop the print spooler first..


telnet 192.168.x.x 9100 (or if you have the port listed from above, try that)
see if you connect or if the connection fails..
If it fails it is network related.. be it firewall on windows, AV, or something else.. but that should at minimal tell us if this is a windows issue or network related..
0
 
admincbfAuthor Commented:
Hi

Thanks for your reply.

> There is no IP address listed for that printer in the reg location you specified
> I cannot connect to the IP address via telnet either on port 9100 or standard port 23
> I CAN connect to that printer via telnet port 23 on another server

So a Windows issue?
0
 
Rob GMicrosoft Systems EngineerCommented:
Admin,
What is the network setup like there?
It sounds like an issue with the network honestly.. or a 3rd party piece of software..
what AV do you run? does it have intrusion protection?
Do you run any Firewalls between the system and the printer?


As a last type of measure you can plug a laptop into that network cable that runs to that server, give it a static IP, use the IP address that the server is using, and try to access the printer, if it works, it is absolutely an issue on that server, what the issue is, sounds honestly still like a firewall or AV issue.. but none the less an issue on that server.. If it doesn't work, and fails on the laptop, you know you have a network issue, without any doubt.. in which case you then need to trace down what changed between the time it did work and now..
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Ok as above network issue or a network routing issue ie unable to route too and back from the Printer to the server.
0
 
admincbfAuthor Commented:
Thanks for your reply

It's a fairly simple setup - we have a Draytek router (as does the remote site) that provides VPN, firewall etc. services.  Neither has been changed since implementation.

I have turned off the Win firewall and paused real-time scanning of our AV on that server.

Personally I am thinking there is something on that server blocking the port or similar to that printer since we can add that printer to any other server we choose without issue.
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
I would try a restart of your network equipment.
Had an issue not long ago with ARP cache on a core switch this was a server though.

Maybe this related.
0
 
admincbfAuthor Commented:
My reason for accepting my own comment as the solution is because my own comment was the solution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.