Solved

how to install the module JSMin in rhel

Posted on 2014-12-11
5
702 Views
Last Modified: 2016-11-27
Dear Experts:

I having rhel 6.6 installed and php , httpd and mysql I am in need to install the module JSMin which Iam not able to locate or identify which package will have to install for this module to be loaded , in the pre-requisite below is suggested  

The following modules are recommended to be running in PHP in order to improve performance:
JSMin

please suggest the package to be installed so that JSMin will be installed and loaded
0
Comment
Question by:D_wathi
  • 2
  • 2
5 Comments
 
LVL 24

Expert Comment

by:mankowitz
ID: 40495200
JSMin is a minimizer for javascript. It takes verbose javascript and condenses it so that it takes up less space. Is this something that you need?

It sounds like you are trying to install SugarCRM, and JSMin should be included in the download.  Check here http://www.sugarcrm.com/download
0
 

Author Comment

by:D_wathi
ID: 40498970
I think with reference to the http://support.sugarcrm.com/02_Documentation/01_Sugar_Editions/04_Sugar_Professional/Sugar_Professional_7.5/Installation_and_Upgrade_Guide/    # JSMin should  does not include in their download they say the following in the above link

PHP

Not only is PHP required to run Sugar, there are specific PHP modules required as well as some specific settings.
The following modules are required to be running in PHP before installing Sugar:

bcmath
curl
gd
hash
imap
json
mbstring
openssl
SimpleXML
zip
zlib
The following modules are recommended to be running in PHP in order to improve performance:
JSMin

suggestion please
0
 
LVL 24

Accepted Solution

by:
mankowitz earned 500 total points
ID: 40501291
JSMin is no longer maintained. See here https://github.com/rgrove/jsmin-php
0
 

Author Closing Comment

by:D_wathi
ID: 40516486
thanks for the update
0
 

Expert Comment

by:az gh
ID: 41903351
Hi,

Following up on this thread:

SugarCRM 7.7 requires JSMin to be installed to run correctly. According to the installation guide here:
http://support.sugarcrm.com/Documentation/Sugar_Versions/7.7/Ult/Installation_and_Upgrade_Guide/index.html

I'm using CentOS 7.

What can I do?

Thanks in advance.
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The purpose of this article is to demonstrate how we can use conditional statements using Python.
Fine Tune your automatic Updates for Ubuntu / Debian
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.
Video by: Mark
This lesson goes over how to construct ordered and unordered lists and how to create hyperlinks.

778 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question