Solved

Word document links won't open in latest Firefox

Posted on 2014-12-11
16
98 Views
Last Modified: 2015-01-06
Hello,

We recently installed the latest version of Firefox on one of our Mac user's computers.  The user is not able to open word document links in the browser.  They do not download or prompt the user to open and/or save.  They just do nothing.  Has anyone experienced this issue and possibly how to fix it?

Thanks,
Mike
0
Comment
Question by:cheesebugah
  • 8
  • 8
16 Comments
 
LVL 53

Expert Comment

by:strung
ID: 40494868
Go in to the FF preferences to the Applications Tab and see what the settings are for "Word Document".
0
 
LVL 53

Expert Comment

by:strung
ID: 40494879
0
 

Author Comment

by:cheesebugah
ID: 40494888
strung,

There is nothing listed for "Word Document."
0
 
LVL 53

Expert Comment

by:strung
ID: 40494911
Do you mean that "Word Document" isn't there or there is no action specified? See screenshot. Does you prefs panel look like that? If not, pleas post a screenshot.
Screen-Shot-2014-12-11-at-4.29.01-PM.pdf
0
 
LVL 53

Expert Comment

by:strung
ID: 40494942
It is also possible that the link the user is clicking on does not actually link to a Word document.

Have your user try this link:

http://grants.nih.gov/grants/funding/416/phs416-7.doc
0
 

Author Comment

by:cheesebugah
ID: 40495054
I was able to get the listing for Word Document into Firefox, but I still cannot open a link on our intranet site to a word document with Firefox.  If I go to the location of the document on our fileserver, it opens just fine.

Thanks
0
 

Author Comment

by:cheesebugah
ID: 40495071
The link you supplied worked just fine.  The links used to work in Firefox before the upgrade to the latest version.
0
 
LVL 53

Expert Comment

by:strung
ID: 40495159
The problem may be the difference between PC and Mac (Unix) paths. If the file path you are using on your intranet is a PC style path with backslashes, it won't work with a Mac which uses forward slashes. (There are other differences too.)

I am not sure why it would have worked with an older version of Firefox.

Can you properly open other types of document on your intranet?
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 53

Expert Comment

by:strung
ID: 40495164
See if anything here helps:

https://wordpress.org/support/topic/create-links-to-files-from-local-intranet

It refers to a Firefox add-on for opening local links. Perhaps you had that add-on in the old version of Firefox, but it is incompatible with the new version and needs updating.
0
 
LVL 53

Expert Comment

by:strung
ID: 40495168
0
 

Author Comment

by:cheesebugah
ID: 40495238
I installed the add-on, which now give me the option of right-clicking on the link and selecting "Open Link in Local Context."  So, when selecting to open the link, I am now taken to "File not found," with the path listed.  This makes me think that this Mac is not understanding the path to the file?  In the second link you just provided, the guy states that he had to add several slashes to get it to work?  What the heck?  This is just crazy.
0
 

Author Comment

by:cheesebugah
ID: 40495244
By the way, it is not just word docs that are having this issue, it is anything associated with a path to the fileserver.
0
 
LVL 53

Accepted Solution

by:
strung earned 500 total points
ID: 40495269
In that case, it is likely the path issue. Macs use Unix path names. Windows uses a different protocol.


Here is a possible solution:  http://www.lobotomo.com/products/WinShortcutter/index.html
0
 

Author Comment

by:cheesebugah
ID: 40505274
I am going to try this, but I have to create a dual boot on the Mac as I am currently running Yosemite, which is not compatible as of yet.  I'm going to try to partition the HD and install Snow Leopard on the second partition.  Please bear with me.

Thanks,
Mike
0
 

Author Comment

by:cheesebugah
ID: 40526237
Is it possible to change the actual links in the html file to work for both Macs and Windows PC's.  I have access to the intranet website html files.  I tried taking out the word "file:" from the beginning of the link, but that broke the Windows links.  

Thanks,
Cheese
0
 

Author Closing Comment

by:cheesebugah
ID: 40534408
This solution worked for me.  Thanks for sticking with me strung.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Introduction If you're like most people, you have occasionally made a typographical error when you're entering information into an online form.  And to your consternation, the browser remembers the error, and offers to autocomplete your future entr…
Citrix XenApp, Internet Explorer 11 set to Enterprise Mode and using central hosted sites.xml file.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now