Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 100
  • Last Modified:

Email not working from Exchange 2010 to 2003

I have started a 2003 - 2010 Exchange migration.  I have moved a handful of mailboxes to 2010, and now those mailboxes cannot email internally to those who still have mailboxes on 2003.  The email sits in the SMTPRelaytoTiRg queue on the 2010 box.  When I ran the Exchange Mail Flow troubleshooter, it reported "Remote server failed the mail acceptance test.  BDAT command Respond=Remote socket is not available."  I have checked everything I can think of, and can't figure out what is wrong.  To make things weirder, earlier today the queue cleared out on its own and the mail was delivered.  But now it is building back up again.  Help!
0
landiiiks2
Asked:
landiiiks2
3 Solutions
 
landiiiks2Author Commented:
Addendum:  I have just discovered that this also applies to external mail that the 2010 mailboxes are trying to send.  The 2010 mailboxes can send fine between each other, and the 2003 mailboxes can send fine to the 2010 mailboxes.
0
 
IvanSystem EngineerCommented:
Hi there,

maybe you are missing some send connectors on exchange 2010? As I remember you cant send email from new server without creating connectors, by default.
Point connector to exchange 2003, like smart host.

Here is a good link: http://www.petenetlive.com/KB/Article/0000234.htm 

Check part that says: Mail will not flow between Exchange 2003 and Exchange 2010

Regards,
0
 
tshearonCommented:
You need to create a bi-directional routing group connector so exchange 2010 can send to 2003. You do this from the exchange management shell:

New-RoutingGroupConnector -Name "Interop RGC" -SourceTransportServers "Your_2010_hubtransport" -TargetTransportServers "Your_2003_bridgehead" -Cost 10 -Bidirectional $true -PublicFolderReferralsEnabled $true

This will enable the rgc to work both ways and also turn on public folder referrals if you use public folders. 2003 will continue to be the bridgehead and send mail to the internet for now. Use this until you are ready to cut completely away from 2003 then remove it and ensure you have a good send connector to your smart host or however you send mail out to the internet.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
landiiiks2Author Commented:
Thanks for your input.  I do have a routing connector that goes both ways which was automatically created when Exchange 2010 was created.  And 2010 has a "read only" send connector from 2003, which I understand is normal until I'm ready to have 2010 start sending out the mail.  But you think I need a different RGC than what is there?  As a further note, four times now, hours apart but with no changes or interaction on my part, the queue spontaneously cleared and mail went out.  Then the queue starts building up again...  That makes me question whether it is a setting that is wrong (which I would think would be all or nothing..).
0
 
VB ITSSpecialist ConsultantCommented:
Sometimes the default RGC that gets automatically created messes up and prevents mail flow. I've had to recreate it several times in the past on separate servers to get mail flow working again even though nothing went wrong during the migration. It's worth recreating anyway as there's no real harm in doing it:

Get-RoutingGroupConnector | Remove-RoutingGroupConnector

New-RoutingGroupConnector -Name “Interop RGC″ -SourceTransportServers “EX2010.domain.com” -TargetTransportServers “EX2003.domain.com” -Cost 100 -Bidirectional $true

Net Stop "Microsoft Exchange Transport"
Net Start "Microsoft Exchange Transport"

Open in new window

Replace EX2010 with the name of your Exchange 2010 server and EX2003 with the name of your Exchange 2003 server, then test mail flow.
0
 
landiiiks2Author Commented:
These were all correct solutions.  In my case it was all set up correctly and it turned out to be a faulty network connection to the 2003 server that was causing the mail to back up.  Everything is now on 2010 and the 2003 server is decommissioned.  Thanks for the help!
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now