mikrotik problem

we are trying to create an eoip between 2 datacenters with given config below

problem is two mikrotik can ping each other with 1.1.1.1 and 1.1.1.3 but from the both network any machine can't get ip address from other sometimes, but sometimes it works :S how this should happen what is blocking them i could not understand

but while they can not get ip address from each side tcpdump -n -q shows that arp requests between networks still going on :S

# dec/11/2014 23:54:00 by RouterOS 6.0

/interface bridge
add name=Kopru protocol-mode=rstp
/interface ethernet
set 0 name=Lan
set 1 name=Wan
/interface eoip
add local-address=xx.xx.xx.22 mac-address=FE:14:B2:B8:92:DD name="EoIP - 1" remote-address=yy.yy.yy.6 tunnel-id=1
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
/port
set 0 name=serial0
set 1 name=serial1
/interface bridge port
add bridge=Kopru interface="EoIP - 1"
add bridge=Kopru interface=Lan
/interface bridge settings
set use-ip-firewall-for-vlan=yes
/ip address
add address=xx.xx.xx.22/27 comment="added by setup" interface=Wan network=xx.xx.xx.0
add address=1.1.1.3/24 interface=Kopru network=1.1.1.0
/ip firewall connection tracking
set enabled=no
/ip route
add comment="added by setup" distance=1 gateway=xx.xx.xx.1







# dec/11/2014 22:04:43 by RouterOS 6.0

/interface bridge
add name=Kopru protocol-mode=rstp
/interface ethernet
set 0 name=Lan
set 1 mac-address=00:50:56:31:A4:F0 name=Wan
/interface eoip
add local-address=yy.yy.yy.6 mac-address=02:A4:C8:60:CB:DA name="EoIP - 2" remote-address=xx.xx.xx.22 tunnel-id=1
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
/port
set 0 name=serial0
set 1 name=serial1
/interface bridge port
add bridge=Kopru interface="EoIP - 2"
add bridge=Kopru interface=Lan
/interface bridge settings
set use-ip-firewall=yes use-ip-firewall-for-vlan=yes
/ip address
add address=yy.yy.yy.6/24 comment="added by setup" interface=Wan network=yy.yy.yy.0
add address=1.1.1.1/24 interface=Kopru network=1.1.1.0
/ip firewall connection tracking
set enabled=no
/ip route
add comment="added by setup" distance=1 gateway=yy.yy.yy.1

Open in new window

FireBallITAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

naderzCommented:
Have you compared notes with Mikrotik wiki? I see you are using firewall and routing settings; which shouldn't be necessary.

See below:
http://wiki.mikrotik.com/wiki/Manual:Interface/EoIP#Notes
FireBallITAuthor Commented:
I have already read them as far as start to trying our networks are so complicated and big some professionals need to ask sth. if needed to resolve
naderzCommented:
Have you tried below on both?

/interface bridge settings
set use-ip-firewall=no use-ip-firewall-for-vlan=no

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.