Solved

Cisco 2960x stack cannot ping HP ProCurve core switch.

Posted on 2014-12-11
18
905 Views
Last Modified: 2014-12-19
Hello EE,

I recently put in a 2960x stack with an uplink on port 47 to an HP Procurve 2910 POE switch.
If I plug into a port on the Cisco stack, I can ping out and access the network/internet/etc.
Port config:
switchport trunk
switchport voice vlan 11
spanning-tree portfast
spanning-tree bpduguard enable

Port 47 on Cisco uplink
switchport trunk allowed vlan 1
switchport mode trunk

If I console into the 2960 and ping the HP it uplinks to port 23 on, I cannot ping it.  Why?
HP port 23 configuration:
trunk 23 trunk1 trunk
untagged vlan 1
tagged vlan 11

Obviously something on my trunk is an issue?
0
Comment
Question by:operationsIT
  • 5
  • 4
  • 3
  • +5
18 Comments
 
LVL 11

Expert Comment

by:Miftaul
ID: 40495464
Do you have default-gateway setup on the switch.
0
 

Expert Comment

by:bergquistcompany
ID: 40495505
Yes, the Cisco router.  
I can get to the Internet and out when connected to any port.  If is when ON the switch via console that I can't ping the switch (HP) between the stack and router.

It seems to be something with the port tying the Cisco into the HP.   Also from remote I will not be able to telnet/SSH to the stack.
0
 
LVL 18

Expert Comment

by:Akinsd
ID: 40495531
Check the IP address and subnet mask you configured on the switch. If the vlan the switch belongs to is not the default vlan, assign at least one port to that vlan on that switch.

The config information you pasted above is not enough to diagnose the issue. Consider posting a censored full config
0
 
LVL 26

Expert Comment

by:Predrag Jovic
ID: 40495835
Looks like something is missing here.
Could you post running configs (remove security details)?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40495945
What VLAN are you using?  Because the only VLAN allowed on the trunk (on the Cisco end) is VLAN 1.

On port 47:
switchport trunk allowed vlan add 11
0
 

Author Comment

by:operationsIT
ID: 40496069
Cisco Config
Current configuration : 25782 bytes
!
! Last configuration change at 04:07:28 UTC Fri Dec 12 2014 by itadmin
! NVRAM config last updated at 04:07:55 UTC Fri Dec 12 2014 by itadmin
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname STACK_10.1
!
boot-start-marker
boot-end-marker
!
enable password 7 123B09474206050A2D3F7426
!
username ITAdmin privilege 15 password 7 072D2D1C1E04100B10065B02
no aaa new-model
switch 1 provision ws-c2960x-48lps-l
switch 2 provision ws-c2960x-48lps-l
switch 3 provision ws-c2960x-48lps-l
!
!
no ip domain-lookup
!
!
crypto pki trustpoint TP-self-signed-3444127360
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3444127360
 revocation-check none
 rsakeypair TP-self-signed-3444127360
!
!
crypto pki certificate chain TP-self-signed-3444127360
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33343434 31323733 3630301E 170D3134 31323132 30333034
  32315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 34343431
  32373336 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A242 574B8C7B F54AE9C0 41FE20BB EE40D504 04585523 326D3CE4 29B6A2FD
  40426163 2212FB07 B89A29FA CEA0E940 3C1E2DF5 02CFEB9E 909C70D3 57DCD50B
  ECBF3DDB AC479EA3 31553093 28A456FD A6C8E088 50B11141 EC2B2C4D 96775AC3
  F7F818B7 452BBB0B 12D8896B D94899F8 BD257101 18AE6872 272D4467 8CC78567
  076D0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 14B2187A ACBF9AA1 C33D29BB 4C547593 DE810DDB 15301D06
  03551D0E 04160414 B2187AAC BF9AA1C3 3D29BB4C 547593DE 810DDB15 300D0609
  2A864886 F70D0101 05050003 8181004B 3FAE11FE 4A4B465C 47A05824 A93E1978
  BCBFE493 A863D29F 9F7FBFB9 B9EDFB86 53795D1B E65C7F87 C9C4C560 2B66D020
  534E87A1 57433D58 28ED5476 5923E86B 31651208 AFDD74AE 761E9980 88BDAC1C
  48EFC3B8 72E1676E 019FF734 5603DC6A F54AE6FB B4D3A3DA 86409B81 91ADD997
  C9815F75 828E6FB7 03CDC168 B9F223
        quit
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface Port-channel1
 switchport mode trunk
!
interface FastEthernet0
 no ip address
 shutdown
!
interface GigabitEthernet1/0/1
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/2
 description USSMUS10002_Accesscards
!
interface GigabitEthernet1/0/3
 description RH_AP7
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/4
 description RH_AP4
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/5
 description RH_AP6
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/6
 description RH_AP3
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/7
 description RH_AP2
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/8
 description RH_AP1
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/9
 description RH_AP9
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/10
 description RH_AP5
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/11
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/12
 description RH_AP8
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/13
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/14
 description patch 44 Konica
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/15
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/16
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/17
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/18
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/19
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/20
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/21
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/22
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/23
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/24
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/25
 description patch 104 DONAUESCHINGEN
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/26
 description patch 20
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/27
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/28
 description patch 36 TC Cheng
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/29
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/30
 description patch 81
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/31
 description patch 59 Technician
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/32
 description patch 4 Gillian Newcomb
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/33
 description patch 56 Param Badyal
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/34
 description patch 60 Technician
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/35
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/36
 description patch 8 Craig Smith
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/37
 description Duvoice
!
interface GigabitEthernet1/0/38
 description patch 26
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/39
 description patch 68 Shipping
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/40
 description patch 114 Mustafa Aziz
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/41
 description patch 12 Sam Singh
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/42
 description patch 118 Paul Jedynak
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/43
 description USSMUS10001
!
interface GigabitEthernet1/0/44
 description USSMUS10001
!
interface GigabitEthernet1/0/45
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/46
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/47
 description uplink to 10.1.16.5
 no mdix auto
!
interface GigabitEthernet1/0/48
 description test port
 switchport access vlan 20
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/49
!
interface GigabitEthernet1/0/50
!
interface GigabitEthernet1/0/51
!
interface GigabitEthernet1/0/52
!
interface GigabitEthernet2/0/1
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/2
 description patch 40 Paul Jedynak
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/3
 description patch 2 Hamburg
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/4
 description patch 6 Drespen
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/5
 description patch 83 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/6
 description patch 84 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/7
 description patch 85 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/8
 description patch 58 Technician
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/9
 description patch 86 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/10
 description patch 34
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/11
 description patch 87 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/12
 description patch 30
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/13
 description patch 46 Vivian Dassios
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/14
 description patch 80 Reute
!
interface GigabitEthernet2/0/15
 description patch 88 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/16
 description patch 28
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/17
 description patch 90 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/18
 description patch 89 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/19
 description patch 92 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/20
 description patch 14
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/21
 description patch 94 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/22
 description patch 93 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/23
 description patch 32 Jason Loroway
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/24
 description patch 24
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/25
 description patch 20 Stephanie Chau Phone
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/26
 description patch 105 DONAUESCHINGEN
!
interface GigabitEthernet2/0/27
 description patch 97 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/28
 description patch 95 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/29
 description patch 98 WALDKIRCH
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/30
 description patch 38
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/31
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/32
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/33
 description patch 50 Richard Hoffman
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/34
 description patch 48 Andrew Newitt
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/35
 description patch 16
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/36
!
interface GigabitEthernet2/0/37
 description patch 116 Nicholas Befas
!
interface GigabitEthernet2/0/38
 description patch 18
!
interface GigabitEthernet2/0/39
 description patch 52 MEERSBURG
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/40
 description patch 42 Konica
!
interface GigabitEthernet2/0/41
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/42
 description patch 54 Lloyd Lorenz
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/43
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/44
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/45
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/46
 description TLink Security wall
!
interface GigabitEthernet2/0/47
 description uplink to 10.1.16.5
 switchport mode trunk
 no mdix auto
 spanning-tree portfast
 channel-group 1 mode active
!
interface GigabitEthernet2/0/48
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet2/0/49
!
interface GigabitEthernet2/0/50
!
interface GigabitEthernet2/0/51
!
interface GigabitEthernet2/0/52
!
interface GigabitEthernet3/0/1
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/2
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/3
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/4
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/5
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/6
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/7
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/8
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/9
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/10
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/11
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/12
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/13
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/14
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/15
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/16
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/17
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/18
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/19
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/20
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/21
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/22
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/23
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/24
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/25
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/26
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/27
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/28
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/29
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/30
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/31
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/32
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/33
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/34
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/35
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/36
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/37
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/38
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/39
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/40
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/41
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/42
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/43
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/44
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/45
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/46
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/47
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/48
 switchport mode trunk
 switchport voice vlan 11
 no mdix auto
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/49
!
interface GigabitEthernet3/0/50
!
interface GigabitEthernet3/0/51
!
interface GigabitEthernet3/0/52
!
interface Vlan1
 no ip address
!
interface Vlan11
 ip address 10.1.16.7 255.255.255.128
 ip helper-address 10.1.16.254
!
interface Vlan20
 no ip address
 ip helper-address 10.1.16.5
 ip helper-address 10.1.16.1
!
ip default-gateway 10.1.16.1
ip http server
ip http secure-server
!
!
!
!
line con 0
 login local
line vty 0 4
 login local
line vty 5 15
 login local
!
end

STACK_10.1#
0
 

Author Comment

by:operationsIT
ID: 40496076
HP Config
; J9146A Configuration Editor; Created on release #W.14.03

hostname "USSMUN10002"
qos dscp-map 101110 priority 6
module 1 type J9146A
interface 11
   speed-duplex 100-full
exit
interface 21
   name "ToNewHP"
exit
interface 22
   name "ToNewHP"
exit
interface 23
   name "ToNewPOEHP"
exit
interface 24
   name "ToNewPOEHP"
exit
trunk 23-24 Trk1 Trunk
trunk 21-22 Trk2 Trunk
ip default-gateway 10.1.16.1
ip routing
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-10,12-20,Trk1-Trk2
   ip address 10.1.16.5 255.255.255.128
   tagged 11
   ip proxy-arp
   exit
vlan 11
   name "VLAN11"
   untagged 11
   ip helper-address 10.1.16.16
   ip address 10.1.16.254 255.255.255.128
   tagged 1-3,5-10,12-20,Trk1
   ip proxy-arp
   ip igmp
   exit
qos type-of-service diff-services
ip route 0.0.0.0 0.0.0.0 10.1.16.1
snmp-server community "public" Unrestricted
snmp-server contact "David Jansen" location "SICK LTD"
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
vlan 1
   ip rip 10.1.16.5
   exit
vlan 11
   ip rip 10.1.16.254
   exit
no autorun
password ****
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40496101
The Cisco stack has 3 switches (which mean 3 port 47's).  I'm guessing that the Cisco port is g1/0/47, right?

The config on that port does not match what you originally posted. It was a trunk, now it's not.

So...

int g1/0/47
 switchport mode trunk

Open in new window


And in the future, please post configs using the "code" feature.  Trying to scroll through a long post like this (especially on a tablet or phone) can be tedious at best.
0
 

Author Comment

by:operationsIT
ID: 40496203
We did have trunk originally but people couldn't get to the internet so switched and now can get to internet just can't ping cisco


Will do sorry first post of code
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 6

Expert Comment

by:LHT_ST
ID: 40496237
I assume from the config on 2/0/47 that you were also trying to set up a port-channel between the switches?

what is your actual goal here? are you just trying to plug 1 switch into your 2960 stack and only allow vlan 11 on the HP?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40496264
Seems to be a bit of a moving target.  ;-)
0
 

Author Comment

by:operationsIT
ID: 40496394
Yes we had port 47 on 1 and 2 in a port channel but they were flapping so we went to one.
Goal: Ping and telnet access to the Cisco from the network.
Router: 10.1.16.1
HP: 10.1.16.5: can't ping cisco
Cisco: 10.1.16.7 - user on a port here can ping router.  console to this switch can't ping HP or router

Ports appear to be working now want to be able to access Cisco switch via telnet/ssh and can't because can't ping it
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40496409
Please post the current configs of both switched and indicate which ports are used to connect to the other switch.
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 40497944
OP was a bit iffy...

switchport trunk
switchport voice vlan 11
spanning-tree portfast
spanning-tree bpduguard enable
That's never going to end well.

Assuming Cisco port 1/0/47 connects to HP port 23, try this...

Cisco side:
int gi1/0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk

Open in new window



HP side:
no trunk 23-24 Trk1 Trunk
vlan 1
 tagged 23
vlan11
 tagged 23

Open in new window

0
 
LVL 26

Accepted Solution

by:
Predrag Jovic earned 500 total points
ID: 40497945
There are many inconsistencies in your configurations.
RIP is almost configured on HP (missing command is #router rip).
ip helper address on HP and Cisco switch are different for VLAN 11.
HP
ip helper-address 10.1.16.16
Cisco
ip helper-address 10.1.16.254

VLAN 11 in first post is not allowed on trunk. Interface VLAN 1 is not configured with ip address.

IP address are also inconsistent - VLAN 11 on HP and Cisco are in different subnets:
Cisco interface VLAN 11 is configured as
ip address 10.1.16.7 255.255.255.128
HP VLAN 11
ip address 10.1.16.254 255.255.255.128

Cisco differently calculates STP cost than HP when Link Aggregation is present - Cisco halves STP cost, HP does not. Default STP on Cisco switches is PerVlanSTP (each VLAN has its own STP instance), while STP on HP switches default STP ihave only 1 instance for all VLANs. HP STP and Link aggregation configuration.

You need to figure this out first.
Do you really need SVI for VLAN 11 on Cisco switch?
Add ip address to SVI for VLAN 1 for telnet or SSH, you don't want to connect PS in voice VLAN for remote administration.
Configuration for port g1/0/48 is wrong if this was part of trunk configuration when you had flapping interfaces.
switchport access vlan 20
switchport mode trunk
switchport voice vlan 11

Open in new window


On trunk you just need
#switchport mode trunk
#switchport trunk allowed vlan 1, 11 (20?)

Make basic configuration  works between switches - ip addresses, VLANs, trunks, and than when your basic L2 config is in working condition you can add details such as Link aggregation.

The easiest way to reset interface to default at Cisco switch is from global configuration mode (just one command per interface):
(config)# default interface g1/0/48
Ports in link aggregation need to have identical configuration (so reset both before start configuration again).
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 40497954
On trunk you just need
#switchport mode trunk
#switchport trunk allowed vlan 1, 11 (20?)

Make basic configuration

Why restrict VLANs then?  Keep it simple... :-)
0
 
LVL 26

Expert Comment

by:Predrag Jovic
ID: 40497956
Yes... You are right. I was just referring to first post - allowed is just VLAN 1.
Author needs to allow other VLANs on trunk. :)
0
 

Author Closing Comment

by:operationsIT
ID: 40508980
Great that is what it was the VLANs were in different subnets so had to get around that.  Thanks for pointing it out.
Trying to clean stuff up here and have a ways to go.  Can't wait to get new switches in (As these are older) and start clean :-)
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now