• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 817
  • Last Modified:

Disabling auto logons in Internet Explorer 11

I have a client that has a problem with Internet Explorer 11 (O/S is Windows 7 Professional 64 bit) auto filling user name and passwords to a couple different websites (that I am aware of). One is Comcast Xfinity. When she opens the Xfinity (xfinity.comcast.net) home page and either clicks Sign In or the Email link it prefills her user name and password and automatically advances past the login screen to her logged in account. It does not stay on the logon screen where her user name and password are entered long enough to change the user name or password.

She also has the same problem with a Blue Cross/Blue Shield of Illinois website (bcbsil.com/producer/). It does the same thing, it brings up the login page to enter the user name and password where both are prefilled and it automatically advances past that page to the logged on account before any changes can be made to the user name and password on the logon page.

At first I thought this was just an issue with the Xfinity page as Comcast has implemented something called HomePass where it will auto logon to an Xfinity user's account to accommodate watching TV on a user's pc. The user has Comcast at home and Comcast Business at work (this is happening while she is at work) but with the BCBS site doing the same thing it looks to be something in IE.

I have gone through all of the settings that I can think of in IE to disable password saving but IE still auto logs on to these two websites.

I have gone into:

 IE settings>Content tab>Auto Complete>Settings and un-checked all boxes and deleted the AutoComplete History

IE settings>General>Browsing History>Delete>Unchecked Preserve website data - checked all other boxes and clicked Delete

IE settings>Security>Internet>Security Level For This Zone>Custom Level>Scrolled down to User Authentication>select Prompt for user name and password

Made a registry entry to disable Internet Explorer password caching:
1.Click Start, click Run, type regedit, and then click OK.
2.Locate and then click the following registry subkey:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
3.On the Edit menu, click New, and then click DWORD Value.
4.Type DisablePasswordCaching to name the new registry entry, and then press ENTER.
5.Right-click DisablePasswordCaching, and then click Modify.
6.Make sure that the Hexadecimal option button is selected, type 1 in the Value data box, and then click OK.
7.Quit Registry Editor.

Reset IE

Opened gpedit.msc>Local Computer Policy>Windows Settings>Security Settings>Security Options>Network Access: Do not allow storage of passwords and credentials for network authentication=Enabled (I was not sure if this would affect IE but I thought it was worth a try)

I am not sure what else I can try. The user is concerned that if she happens to leave her desk that other users could logon to her Xfinity email and more importantly the BCBS site auto logging may be a HIPAA violation.

I would appreciate any suggestions! Thanks in advance!!
1 Solution
ITLighthouseAuthor Commented:
OK...I figured this out. I uninstalled HP Simple Pass and it solved the problem.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now