Automating copying files via Rdp

I currently copy files out from the other Windows VMs  (which I access via Rdp) by selecting it, Copy &
then Paste into my laptop.

I have batch jobs that will create output / csv files in the VMs which I would like to automate copying
out of the files to my laptop.

Don't think I can map a drive from my laptop to the VMs or can it?

Other than writing automon or sophisticated tools, is there any way to automate this copying?
sunhuxAsked:
Who is Participating?
 
Steve KnightIT ConsultancyCommented:
I think the "TestRDPShare" only works through normal windows networking then (though could easily be wrong).  Normally either work in domain environments so it isn't relevant or connecting with servers that are firewalled, DMZ, on the net. etc. with only RDP port 3389 accessible and the Driveletter on Computername, accessible by \\tsclient\c etc. works on all those.

Have attached pic of setting on server and through group policy:

Group policy setting to allow drive redirection
RDP-TCP Proprties - RDP configuration on server
0
 
NVITCommented:
Some ways to have your batch jobs copy to a share...
- If your laptop is on same network as the vm
- Set the Shared Folders setting of the vm (depends on your vm brand)
0
 
Steve KnightIT ConsultancyCommented:
If you are connecting using drives that are showing through the actual RDP session then they are accessible via the UNC \\tsclient\c etc. and can be used with UNC in batch files etc. or map a drive through them, e.g.

net use x: \\tsclient\c

Steve
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
sunhuxAuthor Commented:
My laptop is not on same subnet/VLan as the VM & we have lots of firewalls, switch ACLs
& even a NetiQ PUM (Privileged User Manager) which we must login into & then access
from this PUM

Somehow RDP way of copy & paste works.

Net use x: \\tsclient\c   or   c$  doesn't work
0
 
Steve KnightIT ConsultancyCommented:
ok. Do you have the rdp session set to connect drives, i.e. you can see the client drives selected in your rdp settings in explorer, or do you literally mean copy/paste contents of files via clipboard?
0
 
sunhuxAuthor Commented:
> Rdp set to connect drives
Can you take a screen shot to show where this can be set?

Currently I literally copy/paste via clipboard
0
 
NVITCommented:
sunhux,

I think Steve means in your RDP Connection dialog... Pick Local Resources tab. Under Local Devices and Resources, pick More. Expand Drives. Choose which drive you want to allow.
0
 
Steve KnightIT ConsultancyCommented:
Yes, sorry that was what I meant.  That all channels over the RDP port so works even if there is no other connection between them due to firewalls etc. though can be controlled by policies and other config on the server end, and of course needs enabling on the RDP session.
Steve
0
 
NVITCommented:
sunhux,

I assume you allowed the drive per the Local Resources tab explained earlier.

When you connect, in Windows Explorer, can you see something like TSClient or "C on {FromHost}"? See image C-On-FromHost.

In my image, I rdp from a computer named LAPTOP. So, my remote host shows it as "C on LAPTOP".

Before I connected, on LAPTOP, I created a folder named c:\TestRDPShare. Then, I shared that folder as the same name with Everyone, with Permission Level: Contributor. See image TestRDPShare.

Then, I RDP'd to the remote computer. There, I could open TestRDPShare and copy files to it.

If you can do this also, it can be automated further.
C-On-FromHost.png
TestRDPShare.png
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.