Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

RDP users cannot logon

Posted on 2014-12-12
6
Medium Priority
?
160 Views
Last Modified: 2015-06-03
Good morning,

I am trying to deploy my first Terminalserver outside my test lab.  For this I am running Windows Server 2012 R2 Standard in VMware.  The license server resides on another host (the DC, also 2012R2, also VMware), all the other RD roles are installed locally.  Web Access etc. are not required.  

On my first try, I installed the RDP session host role itself without using the RDP rollout wizard in System manager.  There I received on every user logon the message that no licensing host was configured.  I did not find any means to configure a licensing host.

So I tried again, removed the role and started over using the system manager tools that are meant for running RDP.  I installed the RDP gateway, the session broker and all the rest of it to this host, rebootet twice and I received message that all is well.
Now I cannot connect to this host at all anymore (except via mstsc /admin).  The RDP client asks for credentials and denies access if the credentials are false.  On correct credentials the client seems to connect up to "configuring remote session" - then it fails and I get something like  "the client cannot connect - retry or contact your system administrator".
What really gets me, though, is that I am receiving no messages in eventlog - nothing at all.  Security log shows successful login and logoff for the user, all the rest is void of any information.  This happens on domain users as well as local system administrator user.

I  have assigned  the license server in System Manager and set the licensing mode to "User" which matches the installed and activated CALs.  I did not find any place to grant access privileges to certain users.  

What am I missing?

Thanks,
Ralph
0
Comment
Question by:Ralph Scharping
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 20

Expert Comment

by:Peter Hutchison
ID: 40497804
Load Server Manager, Configuration, Users and Groups and add the Domain Users group to the Remote Desktop users group to allow users to remote onto the server.
0
 
LVL 2

Author Comment

by:Ralph Scharping
ID: 40497989
Do you mean the local group "Remote Desktop Users"?  The Domain-Users-Group is already a member.  But that would have resulted in a proper error message saying that the user is missing privileges, wouldn't it?
I am receiving no error at all - at least not on the server side.
0
 
LVL 20

Expert Comment

by:Peter Hutchison
ID: 40498168
You mentioned Host Licensing is missing. This is a requirement for Remote Destkop services for client CALs. It can be installed via Server Manager as a component of Remote Desktop Services. See picture, you may also want the Connection Broker installed for clients to reconnect to their session.

See picture.
Remote Desktop licensing
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 2

Author Comment

by:Ralph Scharping
ID: 40498811
That is at least not what I meant to say.

On my first try, I did not find means to tell the RDS-Server where to find it's licensing host.  Then I tried over, installed all the roles and was now successful in configuring the licensing host.  Licensing service resides on the DC, that is another VM.
0
 
LVL 2

Accepted Solution

by:
Ralph Scharping earned 0 total points
ID: 40803181
It turns out that some options that are configured in GUI are not read under all circumstances.  It seems that they need to be set using policies:


Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing

“Use the specified RD license servers” = myservername

“Set the Remote Desktop licensing mode” = Per User


That fixed the issue.
0
 
LVL 2

Author Closing Comment

by:Ralph Scharping
ID: 40809831
Took some research...
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
Windows Server 2003 introduced persistent Volume Shadow Copies and made 2003 a must-do upgrade.  Since then, it's been a must-implement feature for all servers doing any kind of file sharing.
In this Micro Tutorial viewers will learn how to use Windows Server Backup to create full image of their system. Tutorial shows how to install Windows Server Backup Feature on Windows 2012R2 and how to configure scheduled Bare Metal Recovery backup.…
In this Micro Tutorial viewers will learn how to restore single file or folder from Bare Metal backup image of their system. Tutorial shows how to restore files and folders from system backup. Often it is not needed to restore entire system when onl…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question