Solved

how do i install a new hard drive into my laptop? Getting error "boot device not found"

Posted on 2014-12-13
8
368 Views
Last Modified: 2014-12-13
I got an hp laptop. model 17- f061Us and I want to install windows 8.1 enterprise, since my work provided me with a copy at no charge. So I  removed the stock hard drive and installed an empty drive in the bay. I don't want to over right the original harddrive yet so that's why I did it on another drive.

I changed the boot order to boot the cd rom drive first and I put in the 8.1 enterprise cd in and reboot the computer. but still when the computer reboots it never asks me if I want to load the files on the dvd, it just gives me a black screen that says boot device not found. please install on OS on your disk.

I ran the diagnostics to scan the drive and it successfully passed the quick scan test, just not sure how to install this 8,1 enterprise on this laptop,

I tested the disk by putting it into my old laptop with xp and sure enough it asks me if I want to boot from the cd when I reboot the computer so not sure why its not working on the new one, any ideas?
0
Comment
Question by:hydrive1902
  • 3
  • 3
  • 2
8 Comments
 
LVL 88

Expert Comment

by:rindi
ID: 40497999
Disable "secureboot" in the BIOS. It may also be necessary to turn off uefi mode.
0
 
LVL 92

Assisted Solution

by:John Hurst
John Hurst earned 250 total points
ID: 40498028
In addition to the above, it also may be necessary to turn AHCI to compatibility mode in BIOS.

I put a new drive in my ThinkPad X230 (blank new drive) with Secure Boot and UEFI on and it worked. HP is a bit different so try all three things.
0
 
LVL 1

Author Comment

by:hydrive1902
ID: 40498066
Ok I disabled secureboot in the bios and that did not fix it, still getting the same black screen saying boot device not found please install the OS.

I went back into the bios and tried to turn off uefl but I could not find such an option. I have to pick one of the three  IPV4 (UEFI) , IPV6 (UEFI) or IPV4 + IPV6 (UEFI) .

And I also checked in the bios for AHCI and I dont even see that option in there.

Anything else I can try?
0
 
LVL 92

Expert Comment

by:John Hurst
ID: 40498080
I wonder if you need to use an HP hard drive or one specified by HP.

Is it the same size. As I said above, I replaced the hard drive in my X230. A 1 TB drive failed to install. I had to use the same type of 500 GB drive that came with the machine,
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 88

Accepted Solution

by:
rindi earned 250 total points
ID: 40498084
There may also be something called CSM. Enable that. Or UEFI could be called differently within your BIOS. On some PC's with Windows 8.x installed, you can also find some BIOS settings within the OS, so you can try booting with your original disk and then look in the OS for any BIOS settings.
0
 
LVL 1

Author Comment

by:hydrive1902
ID: 40498137
Thanks for the info! Both drives are the same brand (seagate) both are 500 gb and both are 5400 rpm.

But I found an option to enable CSM and when I did that the UEFI option disapeared. Just rebooted and now it is installing, thanks everyone!
0
 
LVL 1

Author Closing Comment

by:hydrive1902
ID: 40498140
thanks, got it working!
0
 
LVL 92

Expert Comment

by:John Hurst
ID: 40498141
Thanks for the update and I was happy to help you. Glad it is working now.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

What do we know about Legacy Video Conferencing? - Full IT support needed! - Complicated systems at outrageous prices! - Intense training required! Highfive believes we need to embrace a new alternative.
Stuck in voice control mode on your Amazon Firestick?  Here is how to turn it off!!!
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now