Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

How to correct:  'jpg file couldn't be opened because you don't have permission to view it'

Posted on 2014-12-14
7
Medium Priority
?
6,656 Views
Last Modified: 2014-12-20
Using a folder shared between a MacBook Pro (running OX 10.7.5) and an iMac (running OS 10.10.1).

The shared folder contains jpgs.  All of the jpgs are openable on the MBP but some are not openable on the iMac where they generate the error:  ''The file myfilename.jpg couldn't be opened because you don't have permission to view it'.  The other jpgs in the same shared folder open fine on the iMac.

Tried repairing disk permissions on both machines.  Didn't resolve the problem.

How to fix this?
0
Comment
Question by:qeng
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 70

Expert Comment

by:Merete
ID: 40499905
How many are there could you email them?
Or upload to drop box and then they can download
https://www.dropbox.com/home

 To convert BMP image file to JPG use the " Preview" on Mac then go to File>export to desktop> select jpeg from the export as selection. Choose best quality and save.
0
 
LVL 40

Accepted Solution

by:
Eoin OSullivan earned 2000 total points
ID: 40500117
On the MBP (which can open ALL the images) .. select all the images in the folder (Command + A) and then bring up the Finder Info window (Command + I).
Check the bottom of the Info Window and you'll see the 'Sharing & Permissions' section .. you should probably change the permission to Read & Write for everyone .. and then at the bottom of the dialog .. press the cog icon and apply to any enclosed items (if you have any folders inside the folder).
0
 

Author Comment

by:qeng
ID: 40508902
Merete:  thanks for responding.  It was a permissions problem per eoino's comment.

eoinosullivan:  correct fix.  I had done that previously but inadvertently made the permission changes in a folder with the same name as the shared folder (in a different file directory) and didn't realize it.  Hence the files seen on the iMac were never getting new permissions applied.

Question:  how would I change the permissions on hundreds of images in a folder without having to change them one at at time?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 40

Assisted Solution

by:Eoin OSullivan
Eoin OSullivan earned 2000 total points
ID: 40508919
If you select the folder which contains ALL the images .. get info .. change the permissions on the folder and then in the same dialog .. press the small gear/cog icon and select "Apply to Enclosed" this will set the same permissions on the folder to ALL enclosed files.

Or if you select a large number of files .. (COMMAND + A) then only one Get Info dialog will appear for the batch of files and you can apply the permissions once only
0
 

Author Comment

by:qeng
ID: 40510677
Thx for getting back eoino,

When I follow the instructions in the 1st paragraph of your last comment, the option 'Apply to Enclosed' is greyed out.  I also notice that the padlock at the bottom of the Get Info window is also locked.  I'm able to change the permissions on the selected folder but those permissions aren't passed through to the enclosed folders (imagine a situation, for illustrative purposes, where someone had one folder per year, each containing one folder per month).

To the best of my knowledge, the user account I use on my MBP has admin privileges but I'm guessing there must be some config parameter I need to adjust somewhere which 'unlocks' the settings.

Any ideas?
0
 
LVL 40

Assisted Solution

by:Eoin OSullivan
Eoin OSullivan earned 2000 total points
ID: 40511008
Click the LOCK icon to unlock the permissions and enter your admin password.  You should then be able to change the permissions
0
 

Author Closing Comment

by:qeng
ID: 40511085
Thx for staying with me on this one eoino.  Seems obvious after the tip!
0

Featured Post

Survive A High-Traffic Event with Percona

Your application or website rely on your database to deliver information about products and services to your customers. You can’t afford to have your database lose performance, lose availability or become unresponsive – even for just a few minutes.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

An introduction to the wonderful sport of Scam Baiting.  Learn how to help fight scammers by beating them at their own game. This great pass time helps the world, while providing an endless source of entertainment. Enjoy!
This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question