• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1539
  • Last Modified:

Packet loss on Windows 2012 R2

Hi,

I have a weird problem that I am trying to solve.

We have a hyper-v host running Windows Server 2012 R2 with 3 VMs. The host has 2 network cards Intel 82574L. The first card is configured as the management card for the host and the second is dedicated to the hyper-v external virtual switch.

What happens is this. As soon as I reboot the host, I get a lot of packet loss (about 50%) on the Host but not the VMs. If I change the static IP address, it works just fine but only until I reboot.

I already changed the cards drivers and also tried disabling IPv6 but no success. I also configured the Host on the second card to see if it was a hardware issue but the problem remained.

Thanks
0
Frederic Lalonde
Asked:
Frederic Lalonde
1 Solution
 
Cliff GaliherCommented:
Disable VMQ on the NIC.
0
 
Frederic LalondeAuthor Commented:
I don't have to option in my network card. I also ran the PS command Get-NetAdapterVmqQueue and none are listed.
0
 
Rob GCommented:
Do you have a gateway on both nics?

Do not turn off IPV6 on 2k12 server.. Server 2k12+ uses IPV6 to communicate with other windows 7+ machines on the network, it is helpful if you leave that enabled, even if your LAN Switches and Routers don't support it. Otherwise you can make things worse..
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
Frederic LalondeAuthor Commented:
Hi,

The management NIC has a gateway and the VM NIC is set to use DHCP so that receives one from that. As for the IPv6, it is reactived, it was only a test I did.
0
 
Rob GCommented:
You can't technically use two gateway's in windows.
It will cause this issue, by default windows will automatically choose the best route to use, (Shortest distance) from point A to point B. It sounds like you are having packet loss because you are running two gateways. You can try to fix this by forcing the primary NIC on the system to the one you want to use for your traffic, but generally, windows will still choose shortest route, which in VLAN's etc can cause the system to send out the traffic, but then not be able to get there.

Here are two tests you can do.
Both are going to cause some blip in network productivity.

1. Go to your network connections list (Control panel>Network and Internet>Network connections)
Press the ALT key on the keyboard, choose advanced, then choose advanced settings
Here you will see adapters and bindings,
move the primary NIC to the top of the list using the arrow keys on the right.
Click OK (May cause a blip)

Try this and see if you notice the issue again..
Chances are it won't fix the issue..

2. Remove the gateway from the management NIC and see if that fixes your issue..
I am 99% positive it will..

(Best description.. NIC 1 sends a packet to Desktop A. Desktop A sends a reply, but uses NIC2 as it is a shorter route, Nic 2 has no idea what Desktop A is talking about, NIC2 drops packet from Desktop A. After some time Desktop A might send replies back to NIC 1 but at that point NIC1 doesn't remember what Desktop A is talking about. This causes Latency and Packet loss)
0
 
Frederic LalondeAuthor Commented:
Thanks for your comment.

I had already tried point number 1.

I removes the gateway and still get the same issue unfortunately. One thing to note, the hyper-v was originally using the same network card as the Hyper-V switch and I was having the same issue.

Also, when I reboot, the pings are fine for maybe 15-20 seconds before I start losing packets.

The packet loss are fairly regular, 4 go through and then 4 are lost.
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
I suggest the following:

Remove the current vSwitch.
Team the two physical NICs using the Windows Server Team Wizard.
Create a new vSwitch shared with the host OS.
Bind the new vSwitch to the existing VMs.

Please make sure the most recent version of Intel PROSet is installed on the server prior to the above and also that your backups are good!

Also, I have an EE Article that might be of assistance: Some Hyper-V Hardware and Software Best Practices.

A virtualization platform should eliminate as many single points of failure as possible. A bad cable or switch port the vSwitch was bound to would put a full-stop to the VMs if I understand the description rightly.
0
 
Frederic LalondeAuthor Commented:
Hi and thanks for you suggestion but we would very much like to keep the two NICs separate. Also, we have several other servesr with this configuration and we don't seem to experience this issue.

Do any of you think that it would be a good idea to try with a different NIC? We have a Intel Gigabit Desktop that we could try.
0
 
Frederic LalondeAuthor Commented:
I found the solution. In the end it end up being a defective access point on the network that was creating some garbage,
0
 
Frederic LalondeAuthor Commented:
It fiex the issue as soon as it was unplugged
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now