Solved

Red X on Mapped network drive

Posted on 2014-12-15
14
677 Views
Last Modified: 2016-10-27
On my office computer with Windows 7 Pro, I have mapped a network drive to a folder on my network attached storage device (Intel ss4000-E). Several months ago, the mapped network drive began to disconnect at regular intervals (don't know the duration). The mapped drive displays a red X in Windows Explorer. If I click on the mapped drive entry, the contents of the mapped folder displays and the red X disappears. But after some interval, it disconnects and the red X once again appears. About a year before this started happening, I would have trouble connecting to the NAS; sometimes I have to hard-boot it a couple of times before I can connect to it. But once connected, the connection is stable. My backup routine which is scheduled to run at 6:00 P.M. fails because it "failed to open the data stream" (I'm assuming it's because the mapped drive has disconnected). I have tweaked the registry settings for "lanmanserver autodisconnect" and "lanmanworkstation keepconn" to no avail. I have turned off power management in the wireless network adapter settings on the office computer. There are no settings in the NAS control panel to affect this. I have set LAN Manager authentication level to "Send LM & NTLM - use NTLMv2 session security if negotiated" as suggested in one post.  I've tried all the suggestions an extensive internet search has turned up and nothing works in my situation. Any help?
0
Comment
Question by:wgmichaelis
  • 5
  • 4
  • 3
  • +2
14 Comments
 
LVL 14

Expert Comment

by:Brad Groux
ID: 40501502
It sounds like your NAS is probably disconnecting or going into a power-save mode. The first thing I'd do would be to go to the NAS manufacturer's site and upload to the latest stable firmware build. I'd also scour the NAS's manual for any information about power-save or sleep modes. With make and model information I could provide more detailed steps.
0
 

Author Comment

by:wgmichaelis
ID: 40501567
This is an Intel Entry Storage System SS4000-E.  The latest firmware is installed; no further updates are being developed for this rather old system. Upon scouring the control panel on this device, I find no settings regarding disconnect or power saving modes. I updated the firmware several years ago and the device operated OK until recently. The office computer and NAS are  connected in a simple LAN through a router/switch.
0
 
LVL 6

Expert Comment

by:Francois_IT
ID: 40501588
I have seen this issue before. My case was with DFS namespace disconnecting the root domain due to slow-link detection in the offline files service. Disabeling offline files did the trick.

Another way that can work is to disable the "configure slow-ling mode" in gpedit.msc (Computer Config\Administrative template\Network\Offline Files)

To disable offline files, run the mobsync.exe --> manage offline files --> disable offline files.
0
 
LVL 46

Expert Comment

by:noxcho
ID: 40501642
If you keep a file from this network drive open - does this mark appear?
0
 
LVL 16

Expert Comment

by:joinaunion
ID: 40503397
0
 

Author Comment

by:wgmichaelis
ID: 40505306
I'm working with these suggestions; will post back when I find something. This morning the drive connected at 8:45 when I started the computer (I have a script in the startup folder that connects the network drive); I checked it every now and then, finally at 11:45 I noticed it was disconnected again. But, this time when I clicked on the entry in explorer, a message told me the "drive was not accessible", rather than just connecting. I ran the connection script and the drive connected; this was a new wrinkle I think. The firmware in the NAS is the latest - v1.4b710. Give me some time to work with these suggestions.  Thanks.
0
 

Author Comment

by:wgmichaelis
ID: 40505972
OK, noxcho, I left explorer open, with the contents of the mapped folder showing, and it stayed connected all afternoon -  no red X.  At least now, I think, I can depend on my backup routine running if I leave explorer open.  Does this indicate that Francois IT's suggestion concerning "configure slow-link mode" is the culprit?  I won't be in the shop tomorrow, but Friday when I get back in I'll check and see if the backup routine completed successfully.  Thanks, again, everyone.
0
Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

 
LVL 6

Expert Comment

by:Francois_IT
ID: 40506466
From my experience, slow-link mode was the common issue with our DFSr (could also be the case if simple mapping but cannot be sure). A good way to see if this is the case, look in your event viewer under Application and service logs/Microsoft/windows/OfflineFiles/operational and look for indication that slow-link was detected.
0
 
LVL 46

Expert Comment

by:noxcho
ID: 40506511
I am not using slow link mode on my NAS connection and still it closes automatically the connection. I have to keep a file or folder from this NAS always open to let the backups run. As soon as I close this folder within few minutes the connection is lost.
0
 
LVL 6

Expert Comment

by:Francois_IT
ID: 40507539
0
 

Author Comment

by:wgmichaelis
ID: 40509801
The backup routine which runs Wednesday evening, completed successfully. I had left explorer open showing the contents of the mapped folder when I left. I am not using Offline Files and "slow link mode" is not configured. So, apparently keeping the mapped folder open within explorer keeps the connection connected (am I being redundant?) I find it difficult to believe that there is not a way to keep this connection connected (there I go again) without keeping the folder open within explorer. I am using Acronis for my backup routine, perhaps there is a way to add a script to the front of the backup routine to make the connection first.
0
 
LVL 46

Accepted Solution

by:
noxcho earned 500 total points
ID: 40509830
Yes, there is. Check in Acronis backup wozard if you have a Run Before, Run Dueing and Run After options. Create a batch file which would open a file from this SHARE before the backup starts and then after the backup is done closes the connection in Windows.
https://kb.acronis.com/content/1742
0
 

Author Comment

by:wgmichaelis
ID: 40518722
While I did not find a way to configure Windows 7 to keep the connection to my NAS active, other than keeping explorer open, my ultimate goal was to get my backup routine to complete reliably. This has been accomplished, per noxcho's suggestion, by creating a batch file, containing a script that establishes the connection to my NAS, which is executed by Acronis prior to performing the backup. That method works...mission accomplished.  Thanks, everyone, for your responses.
0
 
LVL 46

Expert Comment

by:noxcho
ID: 40519162
Thanks for feedback and Happy New Year!
Nox
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
SSH commands for Nas4free 21 306
robocopy vs xcopy vs copy 8 58
Windows 7 Share with XP 22 72
How much power fluctionation is too much? 4 35
This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now