• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1117
  • Last Modified:

vb6 and server 2012

Will VB6 applications be compatible with Server 2012 R2 and later versions of Windows server?

Any thoughts
0
al4629740
Asked:
al4629740
  • 4
  • 3
1 Solution
 
Éric MoreauSenior .Net ConsultantCommented:
why wouldn't it be? Any feature in particular you are afraid of not being compatible?
0
 
Éric MoreauSenior .Net ConsultantCommented:
0
 
al4629740Author Commented:
I have an application to use on a server and it was brought to my attention that VB6 "may not run on any OS later than Server 2012 R2, Microsoft hasn't said yet if VB6 compatibility is guaranteed in later versions of Windows"
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
Éric MoreauSenior .Net ConsultantCommented:
vb6 is at least 16 years old, at some point you might have issues for sure.
0
 
al4629740Author Commented:
Can you think of any current issues with the software relative to being out of date?
0
 
Éric MoreauSenior .Net ConsultantCommented:
you might not be able to install the run time on new releases, you might not be able to access devices directly (need to go through newer APIs not available through VB6), ...

As you can see from http://msdn.microsoft.com/en-us/vstudio/ms788708.aspx, there are already some OCX shipped with VB6 that are not supported on newer OSes.
0
 
al4629740Author Commented:
Thank you for the references
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now