?
Solved

install Dll into GAC on SahrePoint 2010 Server

Posted on 2014-12-16
8
Medium Priority
?
49 Views
Last Modified: 2015-06-29
dear all

i want to install a dll on SharePoint 2010 Server, Windows 2008.

this server doesnt have Visual Studio.

how can i install the dll?

and where can i find the GACUTIL.exe ?
0
Comment
Question by:RamzyNEbeid
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 82

Accepted Solution

by:
David Johnson, CD, MVP earned 2000 total points
ID: 40502674
Just drag and drop the dll in C:\Windows\assembly using Windows Explorer (must be an administrator)
0
 

Author Comment

by:RamzyNEbeid
ID: 40504186
i had this message:

assembly Cache viewer - install failed
access denied "dll name"
telerik.web.ui.dll
0
 
LVL 10

Expert Comment

by:Mohit Nair
ID: 40504206
Is that dll gonna reflect something in SharePoint ? In that case, create a wsp solution and deploy it in SharePoint. dll would automatically be mounted in GAC.
0
AWS Certified Solutions Architect - Associate

This course has been developed to provide you with the requisite knowledge to not only pass the AWS CSA certification exam but also gain the hands-on experience required to become a qualified AWS Solutions architect working in a real-world environment.

 

Author Comment

by:RamzyNEbeid
ID: 40504316
it is "telerik.web.ui.dll".

already there is an old version on the GAC.

when we create new web part and try to upload it to SharePoint, it failed.

Could not load file or assembly 'Telerik.Web.UI, Version=2014.1.403.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The system cannot find the file specified.
0
 

Author Comment

by:RamzyNEbeid
ID: 40504342
i was able to add the Dll.

but when i am still getting the same error.

do i need to restart the Server ?

or there is something else needs to be done.

thanks,
0
 

Author Comment

by:RamzyNEbeid
ID: 40504347
it is working now

i uploaded the webpart again.

everything is working very good.

thanks,
0
 
LVL 35

Expert Comment

by:Seth Simmons
ID: 40856626
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question