Solved

install Dll into GAC on SahrePoint 2010 Server

Posted on 2014-12-16
8
40 Views
Last Modified: 2015-06-29
dear all

i want to install a dll on SharePoint 2010 Server, Windows 2008.

this server doesnt have Visual Studio.

how can i install the dll?

and where can i find the GACUTIL.exe ?
0
Comment
Question by:RamzyNEbeid
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 80

Accepted Solution

by:
David Johnson, CD, MVP earned 500 total points
ID: 40502674
Just drag and drop the dll in C:\Windows\assembly using Windows Explorer (must be an administrator)
0
 

Author Comment

by:RamzyNEbeid
ID: 40504186
i had this message:

assembly Cache viewer - install failed
access denied "dll name"
telerik.web.ui.dll
0
 
LVL 10

Expert Comment

by:Mohit Nair
ID: 40504206
Is that dll gonna reflect something in SharePoint ? In that case, create a wsp solution and deploy it in SharePoint. dll would automatically be mounted in GAC.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:RamzyNEbeid
ID: 40504316
it is "telerik.web.ui.dll".

already there is an old version on the GAC.

when we create new web part and try to upload it to SharePoint, it failed.

Could not load file or assembly 'Telerik.Web.UI, Version=2014.1.403.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The system cannot find the file specified.
0
 

Author Comment

by:RamzyNEbeid
ID: 40504342
i was able to add the Dll.

but when i am still getting the same error.

do i need to restart the Server ?

or there is something else needs to be done.

thanks,
0
 

Author Comment

by:RamzyNEbeid
ID: 40504347
it is working now

i uploaded the webpart again.

everything is working very good.

thanks,
0
 
LVL 35

Expert Comment

by:Seth Simmons
ID: 40856626
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Server 2008 Not services listed 23 51
Set Static IP of machine without console access 1 53
c#, case, if 4 22
Set arraylist as datatable 2 13
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
A recent project that involved parsing Tableau Desktop and Server log files to extract reusable user queries for use in other systems. I chose to use PowerShell to gather the data, and SharePoint to present it...
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question