static lib link errors VS2013

Hello Experts,

I have a static library that I built using c++ on VS2008. That lib now needs to be linked in to a DLL that is compiled using VS2013. The VS2013 linker gives the errors that are in the attached file. I need to know what settings I should change in the VS2008 static lib to make this work. Changing the VS2013 DLL app properties is not an option. Compiling the VS2008 static lib with Vs2013 is also not an option.
link-errors.txt
BrianDumasAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jkrCommented:
What are your project's settings, i.e. what is selected under "Configuration Properties|C/C++|Code Generation" as "Runtime Library" and what is "Configuration Properties|Linker|Command Line"?
0
BrianDumasAuthor Commented:
Thanks for the Quick response jkr. I've attached a PDF  file with screen captures of the settings you asked for.
LIB-settings.pdf
0
jkrCommented:
Ah, you have '/NODEFAULTLIB' set. This makes the linker ignore all default libraries, as the name implies. Remove that by going to "Linker|Input" and set "Ignore Default Libraries" to "No".
0
Angular Fundamentals

Learn the fundamentals of Angular 2, a JavaScript framework for developing dynamic single page applications.

BrianDumasAuthor Commented:
Hello jkr, I tried what you suggested and there was no change in the linking errors. they are identical to the original errors. I verified that the change was actually done, and did a rebuild just in case.
0
jkrCommented:
OK, I see that you also have UNICODE set. Can you try to set 'Treat wchar_t as Built-In Type' to 'No'? (You'll find that under "C/C++|Language")
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HooKooDooKuCommented:
Was the library built with Unicode?

Have you tried rebuilding the library in VS2013?

Another thing I've tried when i get libraries the programs that don't want to link due to incompatible project settings is to simply rebuild the projects from scratch (i.e. new project file and simply copy all the source code to the new project).
0
sarabandeCommented:
a static library is a container of object modules which is equivalent to a folder containing object files. because of that, different compilers may produce different object code which cannot be linked together. for example if the vs2008 code calls a c++ function which is no longer available in vs2013 or has different arguments, the linker would not be able to solve this. worse,  a new compiler even could have changed the c++ name mangling (which puts some decoration around function names such that t

the best way out is to follow the advice HooKooDooKu gave and port the static library to vs2013. that solves the issue if the project builds correctly.

Sara
0
BrianDumasAuthor Commented:
I ended up scrapping it since time was running out. The 'Best Solution' got me the closest to having it fixed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
C++

From novice to tech pro — start learning today.