How do I disable anonymous access to my NFTS shares on my windows 2008 servers?

Had a security professional come in and he stated that we had some access security problems; in particular the NTFS shares were allowing "anonymous login's".    I need to disable that function, however I have been unable to find out where or how to do it.

Can anyone give me the steps to do that?
misterdAsked:
Who is Participating?
 
Lionel MMSmall Business IT ConsultantCommented:
Go to the share in question, click on folder properties (right click on folder and then properties), click on the sharing tab, click on sharing or advanced sharing button, then click on add. Then type in "anonymous logon" and then OK and then under the permission select the "Deny" column and deny anonymous access to that share. You will get a warning, read it carefully, and then click OK and test to make sure that making this change will not affect normal operations.
ee-anonymous-acess-warning.jpg
ee-anonymous-acess.jpg
0
 
Cliff GaliherCommented:
It is just a user on the security tab of the files and folders, and is not a default. So someone added it at some point.
0
 
andreasSystem AdminCommented:
to remove it just remove guest access to the shares and disable the guest account if you really dont need it for a special purpose.
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

 
Don S.Commented:
Everyone = anonymous.  So look for any permissions for Everyone.  He may also be commenting on the common practice of granting Everyone full permissions at the share level.  You could change that to "authenticated users" instead on the share level.  That's on the sharing tab not security tab.
0
 
McKnifeCommented:
Why don't you ask that security expert for details?
Anonymous is not the same as everyone. Using everyone in the share permissions does not mean anonymous access is allowed - that was the case with windows 2000, but not any more since win2003.
0
 
misterdAuthor Commented:
Thks that worked for me and the JPG images were helpful as well
0
 
Lionel MMSmall Business IT ConsultantCommented:
glad to help--merry Christmas and happy new year
0
 
McKnifeCommented:
misterd, I am unsure that your issue is solved.
Please ask your consultant to specify what he meant by anonymous access - because by default, anonymous will not have access, as I told you before. Unless someone had added anonymous explicitly by name, it would not have access - and you would have seen that.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.