Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5371
  • Last Modified:

Citrix Receiver SSL Error 14

After the certificate of a Citrix XenApp server was updated, some Windows XP SP3 (*sigh*) clients can't access the published applications anymore.

The Citrix web page is shown, the certifactes are in place and look fine (trusted).

When opening a published app,  SSL error 14 is displayed after a few seconds by the Citrix receiver plugin, http://support.citrix.com/article/CTX113309 says: can't work to the cipher strength required

Update to latest Citrix Receiver (4.2) did not help.
How can I find out which cipher is requested? How can I enable it on XP?
0
Michael Pfister
Asked:
Michael Pfister
  • 2
1 Solution
 
Michael PfisterAuthor Commented:
Downgrade to receiver 4.1 solved the problem. Hope this helps someone ...
0
 
Michael PfisterAuthor Commented:
Did an uninstall of 4.2, manually deleted C:\Program Files\Citix and ran Citrix Receiver cleanup utility http://support.citrix.com/article/CTX137494

Rebooted and installed 4.1 ...
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now