Solved

Citrix Broker assignment

Posted on 2014-12-17
4
65 Views
Last Modified: 2015-01-12
Hi .,I have a machine catalog that contains 15 machines.in vmware. My issue is that when i look at the machines some are assigned to controller 1 under broker and some are brokered from secondary controller. Issue seems that my profile policy is assigned to controller 2 which in turn means machines from controller 1 are not getting the profile policy.
1) how do i manually assign the machines to be brokered from 1 controller (or is this by design) I did create the machines from controller 1's studio console.
2)Should I have 2 policies to cover all the machines in the DG- 1 from controller 1 and 1 from controller 2.

Trying to work out a few issues in this new xd 7.5 environment. More to come but if anyone has any insight to this 1 particular issue I would be very grateful

Ron
0
Comment
Question by:Ron Simpson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 3

Expert Comment

by:CitrixChris
ID: 40504941
This is by design.  Load balancing between the two controllers to even out the load.  You could remove the load balancing, but then why would you want to have two controllers...  Sounds like you need to take a look at your profile configuration.
0
 
LVL 36

Accepted Solution

by:
Carl Webster earned 500 total points
ID: 40504970
As Chris stated, this is by design.  You really do want the Controller to spread the load of the machines they broker between them.  It may not be an exact equal load of machines but it will be very close.

If the policy is assigned to a delivery group (from your other EE question), the policy will (should) be applied to every machine delivered by that delivery group regardless of which controller is managing the machine and connection.
0
 

Author Comment

by:Ron Simpson
ID: 40505027
IM not sure where to look for errors. I had the policy working fine. I would launch Outlook once and configure it. Then I would logoff and launch another session and the outlook profile was already setup meaning the profile policy worked.. I have just deleted my profile from my share and launched a session. the policy must be working because it did in fact created my profile directory but outlook and printers disappear and have to be setup with each session now. I have just set the enable profile management and the path to the user store ( profile storage) I don't think there is anything else I needed to configure in order for profile management to work.

Maybe you have a hint at where I can look for this issue.


Thanks guys

Ron
0
 
LVL 36

Expert Comment

by:Carl Webster
ID: 40505045
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #Citrix Policies #XenDesktop #VDI #POC #Citrix Univeral Printer Driver #Citrix UPD
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question