• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 113
  • Last Modified:

Receiving emails are delayed for certain users

After a successful Exchange upgrade from 2010 to 2013, there are 4 users that have emails delayed both internally and externally. When someone sends the 4 users an email at 11am for example, that user does not receive the email until hours later and sometimes the next day.

There is no 'delayed' message to the sender.

Microsoft Windows Server 2012 R2 /Microsoft Exchange Server 2013 SP1

There are no errors on the server or the users workstation indicating that there is a problem. What else should I be looking at?

1 Solution
Can you check the message tracking logs and see what they say about one of the problem recipients delayed E-Mails? Note the times and the actions specifically and please post the results back here.
Md. MojahidCommented:
1. Make sure that the old server is completely removed from the environment (removed from DNS, Domain, Exchange, ADSIEDIT - Configuration Partition, etc)
2. Make sure that you have properly configured a CAS Array for your Exchange server and pointed all mailbox databases to that array
3. If you have a Public Folder database, make sure that no folders are pointing to the old server and that all mailbox databases are using the new Public Folder database - http://technet.microsoft.com/en-us/library/bb124411.aspx 
4. Make sure that Offline Address Book is not using any legacy Exchange servers - http://technet.microsoft.com/en-us/library/bb124719.aspx 

From the client's perspective, for those users who are complaining, check their Outlook profile for the following:
1. No old Outlook Profiles exist on the client (Control Panel > Mail)
2. Outlook > File > Account Settings -- No old accounts exist under the Email tab (or any other tab for that matter). Typically only have 1 account defined for most users
3. On the Outlook Email account settings > Server Settings, confirm that SERVER value is pointing to the CAS Array for your environment.
4. Under More Settings > Advanced, remove any additional mailboxes and don't download Shared Folders or Public Folder Favorites.
5. Under Security, confirm that Encrypt data is checked and that you have the proper logon network security settings defined based on your environment.
6. Finally, the connection tab should be optimally configured for your environment, to include the HTTP - Exchange Proxy settings if you are using Outlook Anywhere.
go with message header.....Check where is the issue ?

Did you check with new outlook profile from different machine.....Might be antivirus is blocking.
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

bizzie247Author Commented:
Following the steps from Mojahid, I ran into a different issue which I have just hired Microsoft to resolve. They are working through it and when it's resolved, I am hoping that it will resolve this issue. If not, I will continue working your steps. Thanks
bizzie247Author Commented:
I am moving this request to another question which I believe are related. Not sure how to close this one after opening a new one so I will leave it to you or the moderator to let me know if this is the right approach...............


After a migration from Exchange Server 2010 to Exchange server 2013, I turned off the Exchange 2010 Server to ensure mail flow continued before decommissioning it. Users are now getting a ‘Delayed Message’ bounce back when sending email. All mail is stuck in the queue of the Exchange 2013.
When I turned the Exchange 2010 back on again, mail flow was restored and the queue emptied. In testing, when I stopped the service “Microsoft Exchange RPC Client Access”, on the Exchange 2010, the mail was again delayed and stuck in the queue on the Exchange 2013. I restarted that service and everything went back to normal again.
Is there a setting that I can’t see that I should have migrated? Thanks
bizzie247Author Commented:
Thanks for all of your help and suggestions in this but as it turns out, it was a setting that I was looking at without actually seeing!! Under 'Exchange Send Connector'--- Scoping---*Source Server;

The entry still pointed to the old (Exchange 2010). Once I changed it to the new server, mail flowed without going into the QUEUE (delay)
bizzie247Author Commented:
Under 'Exchange Send Connector'--- Scoping---*Source Server;

 The entry still pointed to the old (Exchange 2010). Once I changed it to the new server, mail flowed without going into the QUEUE (delay)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now