Link to home
Start Free TrialLog in
Avatar of raysteinhauser
raysteinhauserFlag for United States of America

asked on

Windows 7 Firewall Question with Peer to Peer network and VPN.

I have two small peer to peer networks at separate locations connected with a SonicWall site to site vpn. I have a Windows 7 Pro machine at one location that I have a shared folder on that users use as a "pseudo" server. I would like the users on the other side of the vpn to have access to that folder but Windows 7 is seeing that network as being a public network and not allowing access to the shared folder. Turning the firewall off on that machine allows access but that's not an acceptable solution. Is there a way to allow or to tell Windows firewall the other network is private or trusted ?
Avatar of David Johnson, CD
David Johnson, CD
Flag of Canada image

if it has a static ip address you can allow that address in the firewall settings
Your easiest fix is to change it to a Work network instead of Public.
Avatar of raysteinhauser

ASKER

Both sides are set to work, it appears since they are on different subnets across the vpn it is seeing the other side as public.
What would I allow through the firewall ? Can I set an exception to allow the entire subnet for the other side of the vpn ?
Here is an article that deals with this.

It's a matter of setting up firewall scopes for File and Printer sharing rules that are already there.
Just add the remote subnet.
Windows-7-File-and-Printer-Sharing-betwe
ASKER CERTIFIED SOLUTION
Avatar of VB ITS
VB ITS
Flag of Australia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Perfect answer, thanks.
It seems to me that SMB-In is only one of the firewall rules that might be productively changed.
As in the instructions I provided.....
Nothing personal, I saw both solutions and was prepared to try them both. I tried the other one first because it was one paragraph and it worked so I gave him the points. Thank you both for responding.