Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Problem to login

Posted on 2014-12-18
22
Medium Priority
?
499 Views
Last Modified: 2014-12-22
Hi,
How to resolve this problem, to login the database?

TITLE: Connect to Server
------------------------------

Cannot connect to PC326VM01\SSEXPR12.

------------------------------
ADDITIONAL INFORMATION:

A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&EvtSrc=MSSQLServer&EvtID=233&LinkId=20476

------------------------------

No process is on the other end of the pipe

------------------------------
BUTTONS:

OK
------------------------------

Open in new window

I'm actually connecting to Sql server, within the same machine.
0
Comment
Question by:HuaMinChen
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 5
  • 5
  • +1
22 Comments
 
LVL 79

Accepted Solution

by:
arnold earned 1500 total points
ID: 40508574
It is one thing connecting to the sql server while connected to it, versus connecting to the sql server from the network.

Double check the sql server configuration to make sure tcp/ip is one of the established protocols ough which a connection can be made.

Try telnet to connect on port 1433 which is commonly the default sql port.

Which sql server are you using, sql 2005? Sql configuration for server you need to enable both shared memory, pipe and tcp/ip protocols.
0
 
LVL 11

Author Comment

by:HuaMinChen
ID: 40508589
I'm using Sql server 2012 express within Win 7 machine.

Sorry, I get this
C:\Users\zcwm>telnet 1433
Connecting To 1433...Could not open connection to the host, on port 23: Connect
failed

you need to enable both shared memory, pipe and tcp/ip protocols.
Can I have more details to this?

Even after I've already enabled TCP/IP, and have put 1433 as TCP port (then have rebooted the machine), I now still get this

Cannot connect to PC326VM01\SSEXPR12.

------------------------------
ADDITIONAL INFORMATION:

A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)
0
 
LVL 52

Expert Comment

by:Vitor Montalvão
ID: 40508675
you need to enable both shared memory, pipe and tcp/ip protocols
Did you enabled all these protocols? Not only TCP/IP but all.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 23

Expert Comment

by:Racim BOUDJAKDJI
ID: 40508978
This looks like an authentication problem rather than a connection problem.  How do you connect AD or SQL login ?
0
 
LVL 79

Assisted Solution

by:arnold
arnold earned 1500 total points
ID: 40510436
The error deals with a lack of an appropriate connection option.

I.e. The client is only allowed named pipes and shared memory, while the server only allowed shared memory and tcp/ip.

The error deals with a protocol mismatch.  When locally connecting shared memory/named pipe work. Remote connections are often using tcp/ip or named pipes.
0
 
LVL 23

Expert Comment

by:Racim BOUDJAKDJI
ID: 40510487
@arnold

Perhaps.  I have never seen this message before.

But this does not surprise me either. This connectivity protocol resolution is always SQL Server culprit.

@HuaMinChen
You need to do some testing to confirm some information:

1>Please make sure the client does use TCIPIP only to connect.  Connect remotely using the IP followed by the IP address as follows (replace the example IP by the IP of the server)       235.36.36.376, 1433
2> Please answer the previous question.  Do you use an Activedirectory, Local admin or SQL Login to connect to the server  to authenticate ?

Waiting for answer to above questions to go further.  Hope this helps.
0
 
LVL 11

Author Comment

by:HuaMinChen
ID: 40512348
Thanks. Can you please advise, what to further adjust within the machine now? I did encounter the problem, while I tried to logon that using Management studio, within the same machine.
0
 
LVL 79

Expert Comment

by:arnold
ID: 40512356
Under start, programs, you should have ms sql that includes a configuration tool. Under the server look at the enabled protocols to make sure all three are enabled.  The change requires the restart of the sql server instance.  Within the same interface, all three should be enabled under the client options.

Within ssms, double check the options prior to attempting the connection to see which option it is trying to use. Named pipes, shared memory, tcp/ip and which port

Etc.
0
 
LVL 11

Author Comment

by:HuaMinChen
ID: 40512373
I can see all the relevant protocols have been enabled below. why did I encounter the problem?
t898.png
0
 
LVL 79

Expert Comment

by:arnold
ID: 40512398
Note the 1433 port is on ip2 supposedly on all interfaces, run netstat -an | find /I ":1433" and look at whether you have a LIstening line.


Note while active is set, enabled is set to no on IP 2.
0
 
LVL 23

Expert Comment

by:Racim BOUDJAKDJI
ID: 40512399
@HuaMinChen

Have you tried doing what I suggested in my last post ?  Please connect only remotely using TCPIP after disabling the other protocols.  Can you do that?  From SSMS, enter the IP in management studio followed by the port number.  I gave you an example and I am waiting for the results.  Unless you do that I can hardly help you further.

@arnold
<<Within ssms, double check the options prior to attempting the connection to see which option it is trying to use. Named pipes, shared memory, tcp/ip and which port>>
The client is one thing but the server resolution of the client request is another thing.  I found the hard way the only reliable way to make sure Non-TPC IP protocols are not involved is to have them disabled on the server (with SQL Browser Service turned off) than troubleshoot from there.
0
 
LVL 11

Author Comment

by:HuaMinChen
ID: 40512401
Racimo,
I disabled these 2 protocols

Shared memory
Named pipes

and then tried to connect to it, from one other machine, using the IP and did get these

Cannot connect to 10.202.6.31,1433.

------------------------------
ADDITIONAL INFORMATION:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - No connection could be made because the target machine actively refused it.) (Microsoft SQL Server, Error: 10061)

Open in new window

0
 
LVL 79

Expert Comment

by:arnold
ID: 40512406
I have all three enabled, make sure the firewall rules on the server allow the inbound traffic. Enabling/disabling protocols requires the restart if the service.

Another issue I've seen deal with an incorrect version of the CLI.

.......
Your error points to sql 2005, while the image reflects sql client version as 11 suggesting it is sql server 2012. In this case the sql client library is the issue for the mismatch.
0
 
LVL 23

Expert Comment

by:Racim BOUDJAKDJI
ID: 40512410
OK.  So know you can be positive that TCPIP access is invisible from your client box and the previous error message was related to non TCP IP resolution.  Looking at your screenshot please make sure the IPAll TCP IP is enabled.  All your IP seem to be disabled.

Under IPAll please change the port from 1433 to some other value to confirm and select enabled under IPAll.  Try reconnect usin other port than 1433 (Ex:5022)

<<No connection could be made because the target machine actively refused it>>
Please temporarily disable your firewall if any and retry.  Thanks
0
 
LVL 23

Expert Comment

by:Racim BOUDJAKDJI
ID: 40512419
As arnold mentionned, please restart your service with each modification
0
 
LVL 52

Expert Comment

by:Vitor Montalvão
ID: 40512506
It can also be a SPN problem.
Can you run the following commands in DOS prompt and post here the results?
setspn -L PC326VM01\SSEXPR12

Open in new window

setspn -L MSSQLAccount

Open in new window

Substitute MSSQLAccount by the account that is being used to run the SQL Server service.
0
 
LVL 23

Expert Comment

by:Racim BOUDJAKDJI
ID: 40512531
<<It can also be a SPN problem>>
True.  

But first, let's eliminating the server configuration and firewall issues.
0
 
LVL 11

Author Comment

by:HuaMinChen
ID: 40512563
I have also created the Inbound rule on TCP port 1433, but I still get the same problem. Here are what I get

C:\Program Files\Microsoft SQL Server\MSSQL11.SSEXPR12\MSSQL\DATA>setspn -L PC326VM01\SSEXPR12
FindDomainForAccount: Call to DsGetDcNameWithAccountW failed with return value 0
x0000054B
Could not find account SSEXPR12

C:\Program Files\Microsoft SQL Server\MSSQL11.SSEXPR12\MSSQL\DATA>setspn -L sa
FindDomainForAccount: Call to DsGetDcNameWithAccountW failed with return value 0
x0000054B
Could not find account sa

Open in new window

0
 
LVL 52

Expert Comment

by:Vitor Montalvão
ID: 40512567
The SQL Server service account isn't sa for sure. Check in services which account it's being used for the service.
For the first SPN try to run with the server name only: setspn -L PC326VM01
0
 
LVL 52

Expert Comment

by:Vitor Montalvão
ID: 40512704
So, what was the issue and how you solved it?
0
 
LVL 23

Expert Comment

by:Racim BOUDJAKDJI
ID: 40512880
Please use a the service domain account for SPN registration.
0
 
LVL 23

Expert Comment

by:Racim BOUDJAKDJI
ID: 40512967
<< how you solved it?>>
I am interested as well :)
0

Featured Post

What Is Blockchain Technology?

Blockchain is a technology that underpins the success of Bitcoin and other digital currencies, but it has uses far beyond finance. Learn how blockchain works and why it is proving disruptive to other areas of IT.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
In this blog post, we’ll look at how ClickHouse performs in a general analytical workload using the star schema benchmark test.
Viewers will learn how to use the INSERT statement to insert data into their tables. It will also introduce the NULL statement, to show them what happens when no value is giving for any given column.
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question