[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Strange MX records issue

Posted on 2014-12-18
3
Medium Priority
?
144 Views
Last Modified: 2015-04-07
After pointing the MX records to Office 365, the email is not flowing anymore.

When I do a "Find and fix issues" in the Office 365 portal, I get this error:

Capture.PNG

The MX records are clearly not setup this way at the DNS registrar.

I'm not sure if it's clear from the picture but basically it says that the domain is added at the end one more time.

Any help would be appreciated.
0
Comment
Question by:Alan Dala
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 36

Assisted Solution

by:Kimputer
Kimputer earned 1000 total points
ID: 40508744
I think YOU really did set it up wrongly. Probably because your DNS registrar web interface allows you to fill in servers BEFORE the domain name. (usually a text block, and behind it the domain name your administrating, as that's usually what is expected in this admin panel).
If there's no way to have FULL freedom to fill in your DNS settings, just get in touch with support (either they will show you how to fill in an entry unrelated to your own domain name, or they will manually add it for you).
It's quite logical though. DNS admin panels are designed to make it easy for you to add entries for
mx.domain.com
server1.domain.com
server2.domain.com
where you fill in only the first part, to help you minimise making typos. In this case though, you need to get outside this ease of use parameters.
To double check that your MX record is really wrong, you can do a nslookup against google's dns 8.8.8.8 and see that you're really wrong.
0
 
LVL 5

Accepted Solution

by:
Leon Kammer earned 1000 total points
ID: 40508785
Hi,

Microsoft put out a statement earlier in the year regarding this.

All domain specific MX records must be changed to
yourdomain-tld.mail.eo.outlook.com or
yourdomain-tld.mail.protection.outlook.com to avoid service flow disruption.

IIRC this was sometime around July.

Also ensure that you have set the spf correctly

"v=spf1 include:spf.protection.outlook.com -all"
Cheers

Leon
0
 

Author Comment

by:Alan Dala
ID: 40510234
I forgot to add the .(dot) after com. WOW! Some DNS providers need that .(dot), some not.


Thanks everyone for the help!
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
Want to know how to use Exchange Server Eseutil command? Go through this article as it gives you the know-how.
In this Experts Exchange video Micro Tutorial, I'm going to show how small business owners who use Google Apps can save money by setting up what is called a catch-all email address in their Gmail accounts. By using the catch-all feature, small busin…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question