MTU setup on WS-C6509-E

I am unable to set MTU on interface. It says unrecognized command
AAA(config-if)#mtu ?
% Unrecognized command
AAA(config-if)#mtu
                          ^
% Invalid input detected at '^' marker.

Open in new window

Here is the switch details:

cisco WS-C6509-E (R7000) processor (revision 1.3) with 458720K/65536K bytes of memory.
Processor board ID SMG1119N26C
SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
Last reset from s/w reset
13 Virtual Ethernet interfaces
196 Gigabit Ethernet interfaces
1 Ten Gigabit Ethernet interface
1917K bytes of non-volatile configuration memory.
8192K bytes of packet buffer memory.

65536K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102

Open in new window


 Thank you in advance for your help.
LVL 11
MiftaulAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rharland2009Commented:
Which interface are you attempting to change the mtu on? Is it virtual, gig, or 10gbE?
0
MiftaulAuthor Commented:
Its a Gigabit Ethernet port. I want to set MTU size 9000 to connect these ports to iscsi.

AAA#sh int gi 4/41
GigabitEthernet4/41 is up, line protocol is up (connected)
  Hardware is C6k 1000Mb 802.3, address is 001c.58d3.7308 (bia 001c.58d3.7308)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseT
  input flow-control is off, output flow-control is off
  Clock mode is auto
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/2000/233/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 3000 bits/sec, 1 packets/sec
     961742 packets input, 1295301272 bytes, 0 no buffer
     Received 23 broadcasts (0 multicasts)
     0 runts, 607 giants, 0 throttles
     607 input errors, 0 CRC, 57 frame, 233 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     276919 packets output, 82434294 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Open in new window

0
RafaelCommented:
Is CEF running? Can you post a clean copy of your running config?

Otherwise normally it should be

router#config r
router#int gi 4/41
router#(config-if)description To XXX
 router#(config-if)shutdown
 router#(config-if)mtu 9216
 router#(config-if)no shutdown

post running config please

HTH
-Rafael
0
CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

rharland2009Commented:
You can check with Cisco support on this, but here's what it looks like.
This is an L2 interface. If I recall, you cannot set the MTU per-interface on L2 ports - only globally.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MiftaulAuthor Commented:
CEF is running, please see attached.

AAA#sh cef inter gi4/41
GigabitEthernet4/41 is down (if_number 389)
  Corresponding hwidb fast_if_number 389
  Corresponding hwidb firstsw->if_number 389
  Internet Protocol processing disabled
  Hardware idb is GigabitEthernet4/41
  Fast switching type 22, interface type 146
  IP CEF switching enabled
  IP CEF switching turbo vector
  IP Null turbo vector
  IP prefix lookup IPv4 mtrie generic
  Input fast flags 0x0, Output fast flags 0x0
  ifindex 388(388)
  Slot 4/0 (4) Slot unit 41 VC -1
  Transmit limit accumulator 0x0 (0x0)
  IP MTU 0

Open in new window


I can not enter "MTU 9216" interface command. It says unrecognized. Please see the below output.

AAA(config)#int gi 4/41
AAA(config-if)#shut
AAA(config-if)#mtu 9216
                          ^
% Invalid input detected at '^' marker.

AAA(config-if)#
AAA(config-if)#do sh run inter gi 4/41
Building configuration...

Current configuration : 140 bytes
!
interface GigabitEthernet4/41
 switchport
 switchport access vlan 130
 switchport mode access
 shutdown
 spanning-tree portfast edge
end

Open in new window

0
MiftaulAuthor Commented:
I tried setting  MTU globally using "AAA(config)#system jumbomtu 9216" but still it doesn't change MTU to interface.

AAA(config)#do sh int gi 4/41
GigabitEthernet4/41 is up, line protocol is up (connected)
  Hardware is C6k 1000Mb 802.3, address is 001c.58d3.7308 (bia 001c.58d3.7
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

Open in new window

0
rharland2009Commented:
Changes won't take effect until you reload the switch.
0
MiftaulAuthor Commented:
I reloaded the switch last night after enabling the jumbo mtu, that didnt help.
The problem is many people are connected to the switch so can not reboot.

As you advised, I am going to reboot it again tonight.
0
vipeliteCommented:
Set it globally reboot then add it to the interface in question.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.