?
Solved

2008r2 Remote Desktop not allowing non admin users to connect

Posted on 2014-12-19
3
Medium Priority
?
487 Views
Last Modified: 2014-12-20
Just repurposed an old Exchange server to remote desktop.  Disabled all Exchange services and added session host role.  It is using 2 other licensing servers on the network.  Have user account in the local remote desktop users group but it says that  user is not in the group when I try to log on.   Ran the licensing diag and it shows 30 licenses available between both servers.  The same group policy as the old TS is applied to the new TS.   Can't figure out why it won't allow clients to log on.  Is something perhaps wrong with the RDP allowed users group?

Thanks.
0
Comment
Question by:YMartin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 2

Expert Comment

by:great_gentle_man
ID: 40510441
open the Control Panel -> System -> Remote settings and click on the Select Users and verify that required user/group is present in allowed users
0
 
LVL 24

Accepted Solution

by:
VB ITS earned 2000 total points
ID: 40510680
Check either Group Policy or the Local Computer Policy (click Start > Run > type in gpedit.msc) and go to Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment\

Open Allow log on through Remote Desktop Services and make sure the Remote Desktop Users group is in there. Similarly it will also be worth checking the Deny log on through Remote Desktop Services and making sure this setting isn't enabled, or the Remote Desktop Users group isn't listed in there.
0
 
LVL 1

Author Closing Comment

by:YMartin
ID: 40510806
I checked RSOP and the allow log on is not defined.  Checked local gpedit and only administrators were defined.  Added remote desktop users and reboot.  All's good.  Looks like somone altered it on the Exchange server or it was never set by the installer.

Thanks for the exact setting.  Saved my weekend.
0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

At the beginning of the year, the IT world was taken hostage by the shareholders of LogMeIn. Their free product, which had been free for ten years, all of the sudden became a "pay" product. Now, I am the first person who will say that software maker…
New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question