How hide local report subreport when no data?

I already try several actions, including some here in EE.
The report still showing blank row in the place of the subreport.
Deraldo SilvaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Deraldo SilvaAuthor Commented:
Hi. News.
well the problem really is not only to hide the subreport. Is to hide the tablix row in the main report that holds the subreport. Even when I hide the subreport by force (using true directly on visibility tab)

Setting the row visibility to hide, I could remove the line space. but I need the space when the report has some rows.

thx in advance
0
Deraldo SilvaAuthor Commented:
Workaround.
I just set the row height to almost zero. It is not an elegant solution, but it works. When there is any record in the subreport, the line expands to hold the report. The problem is that I can not set the height to zero. so there is always a white, short line, but it's there.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
C#

From novice to tech pro — start learning today.