Solved

vmware vsphere client console black

Posted on 2014-12-22
19
334 Views
Last Modified: 2015-01-01
Hello Experts,

I'm getting a blank screen when I attempt to view my VM through console screen.

I'm following the recommendations from the following knowledge base:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2003854

However, each time I add permissions I get the following error message

 vm
Can someone help me please

Cheers

Carlton
0
Comment
Question by:cpatte7372
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 12
  • 6
19 Comments
 
LVL 120

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 500 total points
ID: 40512979
By Default with Default Permissions without changing them as an Administrator, you should be able to view the console.

Is Port 902 TCP being blocked?

e.g. telnet <ip address> 902

if you get no connection, it's blocked.

The console is a custom version of VNC via Port 902.
0
 

Author Comment

by:cpatte7372
ID: 40512983
Hi Andrew,

I have just rebooted server. I will try that suggestion when it comes back
0
 

Author Comment

by:cpatte7372
ID: 40512990
Hi Andrew,

When I telnet I get the following error message:

220 VMware Authentication Daemon Version 1.10: SSL Required, ServerDaemonProtocol:SOAP, MKSDisplayProtocol:VNC , VMXARGS supported, NFCSSL supported
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 120
ID: 40513000
Okay, that is how it should respond.

and you still get a black screen on ALL VMs ?

also check that you can resolve the ESXi server IP Address by hostname, and fqdn

so check with ping and tracert to hostname and iP Address
0
 

Author Comment

by:cpatte7372
ID: 40513056
Hi Andrew,

I'll check.

I should mention that I don't have this problem when connecting from home.
0
 

Author Comment

by:cpatte7372
ID: 40513072
Hi Andrew,

The server hasn't been defined with an fqdn.

I am hiring it online from 'Bare Metal Servers'
0
 

Author Comment

by:cpatte7372
ID: 40513076
and you still get a black screen on ALL VMs ?

yes
0
 
LVL 120
ID: 40513098
so, if you have got a fqdn, created one!

edit your hosts file and add

192.168.1.100 server100.myserver.com

and then use the vSphere Client to connect to server100.myserver.com
0
 

Author Comment

by:cpatte7372
ID: 40513188
So Andrew,

I added the following;

64.xx.xx.xx            bmetal.noc.baremetalcloud.com

But when I ping the name its not resolved
0
 

Author Comment

by:cpatte7372
ID: 40513190
I don't understand why I don't have the same problem from my home?
0
 
LVL 120
ID: 40513221
name resolution, DNS.

if you ping bmetal.noc.baremetalcloud.com

it should resolve and ping

create a simpler DNS name
0
 

Author Comment

by:cpatte7372
ID: 40513232
Hi Andrew,,

So I creates as shown below,


but still won't resolve the name


# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#      127.0.0.1       localhost
#      ::1             localhost
64.xx.xx.xx            bmetal.noc.baremetalcloud.com
0
 
LVL 120
ID: 40513263
just put the word....

64.xx.xx.xx server

ping server

does it resolve to server, and ping.....

you may also want to do a

ipconfig /flushdns
0
 

Author Comment

by:cpatte7372
ID: 40513264
Oops!

I added the following:

64.xx.xx.xx            bmetal.baremetalcloud.com
0
 

Author Comment

by:cpatte7372
ID: 40513272
OK, I'll try that
0
 

Author Comment

by:cpatte7372
ID: 40513284
Andrew

I tried exactly
C:\Users\Pattec01>ping server
Ping request could not find host server. Please check the name and try again.
0
 
LVL 120
ID: 40513296
Are you editing the hosts file?

are you saving the hosts file?

are you editing the hosts file as Administrator ?

something weird or not correct with your hosts files.

host file is normally located in windows in

c:\windows\system32\drivers\etc\hosts

so if you do....

type c:\windows\system32\drivers\etc\hosts

what do you get ?
0
 
LVL 5

Expert Comment

by:Dawid Fusek
ID: 40514133
hi mate,

The black screen on VI/vSphere Console can be caused due to the following reasons
 
1. As Andy suggests, issues related to DNS/FQDN of host/guest
Verify the DNS/FQDN of both ESXi host and guest
 
2. ESXi host may need to restart management agent services (kb1003490)
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1003490
Check the other VMs hosted by the same ESX/ESXi host.If they don’t have issue this may not be the cause
- here also sometimes happens that VM Console are working when You concect directly to ESXi host but not working when You connect via vCenter Server connection, then it's a problem with vCenter Server (fw, services. lack of memory or disk space).

3. Video memory of VM is too small for WDDM video driver
  (C:\Program Files\Common Files\VMware\Drivers\wddm_video\)
I suggest video RAM increase to 32-64 MB (kb1016770), it sometimes happens that older vm's (or virtual appliances) may have as little as 4MB which is too small to work correctly in most cases
 
4. Firewall blocking ports 902/903 (kb749640)
- fw may do it on the ESXi host (do it when you access it via HTTP Proxy or sometimes via VPN or other LAN segment):
To enable port "on proxy", do this
   Log in to ESXi, open /etc/vmware/config
   add line -
   vmauthd.server.alwaysProxy = "TRUE"
 service mgmt-vmware restart    (it will restart all management services on ESXi host)

- FW may do it on your workstation
So check local fw rules, maybe disable fw for a while to test it with disabled fw (Enable FW again after test !!!)

- using a WWW/HTTP proxy server on a management workstation
/set in Control Panel/Internet Options/Connections/LAN Settings/Proxy Server/Address
or
/set as via GPO as a windows system proxy (check by command "netsh winhttp show proxy")
check without a proxy

- company FW may also block access to these ports, so contaxt an corporate FW admins

QUESTIONS:
Are this problem come to other vm or 1 particular vm?

Are you connect via vCenter Server or directly to ESXi? if via vCenter Server, do You check directly to ESXi? is the situation the same?

To troubleshoot this you can also connect via RDP to some VM on that ESXi (but not to that which you have a problem) and then install vSphere Client here and then connect to Console again and check if it working, if working ok the problem is rather closer to yous workstation/FW/DNS or LAN/FW, but if not working the problem may be closer to ESXi itself, DNS or vCenter Server or VM video ram.

best regards
NTShad0w
0
 

Author Closing Comment

by:cpatte7372
ID: 40527083
Thanks Andrew
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Last article we focus in how to VMware: How to create and use VMs TAGs – Part 1 so before follow this article and perform the next tasks, you should read the first article how to create the TAG before using them in Veeam Backup Jobs.
In this article, I will show you HOW TO: Create your first Windows Virtual Machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, the Windows OS we will install is Windows Server 2016.
Teach the user how to convert virtaul disk file formats and how to rename virtual machine files on datastores. Open vSphere Web Client: Review VM disk settings: Migrate VM to new datastore with a thick provisioned (lazy zeroed) disk format: Rename a…
Teach the user how to use configure the vCenter Server storage filters Open vSphere Web Client:  Navigate to vCenter Server Advanced Settings: Add the four vCenter Server storage filters: Review the advanced settings: Modify the values of the four v…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question