Solved

RDP Not Working On Non-Default Port

Posted on 2014-12-22
5
174 Views
Last Modified: 2014-12-22
Ok - so here's the deal.  I have changed the default Terminal Services port (RDP) for TCP & UDP on my Sonicwall router.  I've also changed the port for RDP in regedit on 4 Win7 computers that are the hosts.

3 of them work no problem with the new specified RDP port number both internally and externally.

One stubborn PC won't work with RDP after the port number change either internally or externally.  I've checked Windows Firewall on that specific PC and all looks ok.  

If I go back to Regedit and change the port back to 3389 on the offending PC it at least works internally (obviously it would not work externally due to Sonicwall pointing to a different port).   If I change it again to my new port number it's a no-opp.  This PC had no problem with external access before the port change and no problem if it's set to 3389.  If I open 3389 backup on my Sonicwall I can re-access this cruel and heartless PC.

Any Ideas?  THANKS for any help & Happy Holidays to all!!
0
Comment
Question by:Frank Fratzke, CPA
5 Comments
 
LVL 6

Expert Comment

by:Rob G
Comment Utility
If you change it back to the custom port and from the PC with the issues, run a Netstat -aon | find /i "3389" from a command prompt, do you see the system listening on that custom port?
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 500 total points
Comment Utility
Is there any 3rd party security software that night be blocking the port.  If so it has to be configured as well.  You might also try disabling the Windows firewall just as a test.
0
 
LVL 68

Expert Comment

by:Qlemo
Comment Utility
As a side note, you do not need to exactly match external and internal port. It can make life easier if you do, but sometimes leaving the internal port at its default is a better idea ...
 I'm pretty certain the SonicWall is able to do a port translation.

Did you check without Windows Firewall, to have that excluded for sure?
0
 

Author Comment

by:Frank Fratzke, CPA
Comment Utility
Thanks guys, netstat shows that it is listening on my new port number, but turns out that Windows Firewall was the culprit after all.  I turned off the section "Domain Network Location Settings", and poof! it worked.  This seems strange because the other 3 PC's have the Win Firewall turned on across the board.  The firewall is set to allow both Remote Desktop and Remote Desktop -RemoteFX.  Interesting?!  Any comments about any further Win Firewall settings to look at?

THANKS AGAIN!
0
 
LVL 6

Expert Comment

by:Rob G
Comment Utility
Frank,
I would only suggest you make the settings changes in group policy and save the policy with the settings change. So that way in the future, you can have everything be the same.. I bet you the culprit in this firewall setting is how windows now handles which firewall rules it runs,. You can hit that setting, to make it see every network as a public, or work,or whatever the other one is, i wonder if the difference here is the "where windows" thinks the network is work, vs public.. and is changing the settings on you after the fact.. I have seen that before.. Do you have group policy set to make these machines always treat all networks as a certain type? I ask that because in addition to what i listed above, if the wireless network is enabled, and you have the wifi on while hard wired, windows will treat everything as public.. which jacks everything up.. ;)
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

The Need In an Active Directory enviroment, the PDC emulator provide time synchronization for the domain. This is important since Active Directory uses Kerberos for authentication.  By default, if the time difference between systems is off by more …
This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now