Spanish characters in HTML

I uploaded some Spanish web pages someone else provided and I'm seeing many unrecognized characters.

http://bible-truths.com/Spanish/LOFp16D2.htm

I add <meta charset="UTF-8"> thinking that would help but they still don't look right.

What do I have to do to make these pages look good?

Thanks
NDennisVAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hieloCommented:
You need to save the contents of the html file as utf-8.  Does your editor have the option to save the content in UTF-8 encoding? If not, try a different editor like Notepad++.
0
HainKurtSr. System AnalystCommented:
add this

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
...
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

if this one does not help, looks like you have same issue i had before... files are saved as ASCII and browser cannot detect it correctly... no matter what you do with meta/charset, it does not fix... so make sure you saved the files correctly...
0
NDennisVAuthor Commented:
"files are saved as ASCII"

I use Frontpage - It's old but should save correctly.

But I'll do some testing and get back here in a few days.

Thanks
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

NDennisVAuthor Commented:
Opening the HTML file in my browser (not preview) from within FrontPage, it all looks perfect.

But after I upload the same file and run it in the same browser (Chrome) I see all the unknown characters.

I make some small changes to make sure I'm looking at the most recent uploaded file.

Any ideas why?
0
HainKurtSr. System AnalystCommented:
just save files in UTF-8... file > save as and here there should be some settings... do not use ASCII
or use any other editor like (Notepadd++, even Notepad)  and open your files one by one and save them in utf-8 format...
0
NDennisVAuthor Commented:
I do not have an "UTF-8" option to "save as" in FrontPage.

Thanks
0
GaryCommented:
It should already be saving them in UTF anyway.

Can you attach a copy of the relevant page here (not post but attach)
0
HainKurtSr. System AnalystCommented:
I do not have an "UTF-8" option to "save as" in FrontPage.

then use notepad! after saving with frontpage, open them with notepad and save with utf-8
0
hieloCommented:
>>I do not have an "UTF-8" option to "save as" in FrontPage.
Save current document to UTF-8
Format > Background > Language > HTML encoding > Multilingual (UTF-8)
Set default encoding to UTF-8
Tools > Page Options > Default Font > Multilingual (UTF-8)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
NDennisVAuthor Commented:
Please give me a few days hielo.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
HTML

From novice to tech pro — start learning today.