Remote Desktop Disconnecting from Servers after inactivity in Active Directory Domain

The remote desktop connection in our domain servers disconnect sessions after a few minutes in inactivity.

I disabled these options on the default domain controllers and default domain policy:

Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

User Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits
RemoteDesktopSettings.PNG
Stephen Weber - MCSE, CCNATechnical System Analyst / Enterprise AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

VB ITSSpecialist ConsultantCommented:
Without knowing more about how your OUs are structured and which servers are experiencing this issue, I can only suggest you try disabling the time limits on the servers themselves via Administrative ToolsRemote Desktop ServicesRemote Desktop Host Configuration > right click on RDP-Tcp in the Connections box > PropertiesSessions tab > make sure End a disconnected session is set to Never

It's probably best you separate out these settings into a new policy, that way you can check using RSoP or gpresult to see whether the policy is applying or not. If you need a hand with RSoP you can do some reading here: http://technet.microsoft.com/en-us/library/cc736424(v=ws.10).aspx
0
Spike99On-Site IT TechnicianCommented:
We had this issue a few years ago on Server 2003 for users connecting over to our servers using TSGateway over a regular internet connection. After much googling & investigation by the networking team, we finally figured out that cause was a particular type of firewall that was cutting off the connections after only a few minutes of inactivity.  Some users actually had been disconnected because of internet issues on their end, but the servers failed to recognize that fact & displayed those sessions as "active." So, when those users tried to reconnect, they were put into a duplicate session instead of being reconnected to their previous session.

The solution we found was to enable the "KeepAliveEnable" policy in our Terminal Server GPO.

This not only kept actively connected users from getting disconnected, it also gave us a more accurate picture of which users were connected or disconnected so if a user was disconnected, the server would show them as disconnected.

Although, you should keep in mind that MS has found an issue when manually stopping the RDP service with the KeepAliveEnable policy enabled: it can put the server into an unstable state.

Read this article about that:
http://support.microsoft.com/kb/2507353

I hope this helps.

Alicia
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Stephen Weber - MCSE, CCNATechnical System Analyst / Enterprise AdministratorAuthor Commented:
Alicia,

Thanks for the recommendation.  This is all on the local lan and applies to all our servers using a direct RDT Connection. I setup the group policy not to time out. All the workstations will not time out, its just the servers.

thanks
Steve
0
Spike99On-Site IT TechnicianCommented:
Our problem was caused by a known issue with the the settings on the particular brand of firewall we had, but that's not the only cause of that type of issue.    I would still give the KeepAliveEnable setting a try, do you have a test server you could try it out on?
0
Stephen Weber - MCSE, CCNATechnical System Analyst / Enterprise AdministratorAuthor Commented:
Thank you,.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.