Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Hyper-v Converged Network - Unable to ping/communicate

Posted on 2014-12-23
3
Medium Priority
?
304 Views
Last Modified: 2016-11-23
Hi, we currently have this topic also open on the technet forums and Eric Siron has been kind enough to help out however we are getting desperate.

We have a very simple environment.  2 x Dell R520 node running server 2012 STD.  Hyper-v setup on each node (Vanilla with no other roles)
Each node has 2 x onboard broadcoms and 1 x 4 port Intel Nics.

2 of the ports from the Intel nics on each node are used in MPIO for ISCSI shared storage via the SaN.  This works perfectly.
The remaining ports (2 x broadcom + 2 x intel) are teamed as follows:
Switch Independant, Dynamic, All Adapters Active. Team Name: ConvergedNetTeam

A Vswitch is created : New-VMSwitch -Name ”External” -MinimumBandwidthMode Weight -NetAdapterName “ConvergedNetTeam”

The Management nic created is renamed to management.
We then create 2 more networks for Cluster and Migration and assign to External vswitch.

MinimumBandwidthWeight 5 for Management
MinimumBandwidthWeight 20 for Cluster
MinimumBandwidthWeight 30 for Migration

DefaultFlowMinimumBandwidthWeight for Vswitch set to 10

All connected to a Cisco 3750 Switch with minimal config and all ports in switchport mode access (allocated to vlan1/Native)  No other vlans configured on the switch.  Once in production there will be 2 x Cisco switches stacked.

At this stage connectivity between nodes on the different subnets/vlans is fine.

As soon as we apply the VLANID's to the networks we loose connectivity :

Set-VMNetworkAdapterVlan -ManagementOS -VMNetworkAdapterName “Management” -Access -VlanId “2”
Set-VMNetworkAdapterVlan -ManagementOS -VMNetworkAdapterName “Migration” -Access -VlanId “6”
Set-VMNetworkAdapterVlan -ManagementOS -VMNetworkAdapterName “Cluster” -Access -VlanId “7”

We then change the following on the switch :

switchport trunk encapsulation dot1q
switchport trunk allowed vlan all
switchport mode trunk

create the vlan interfaces
int vlan 2
no ip address

int vlan 6
no ip address

int vlan 7
no ip address


We have tried breaking up the team and not using the broadcoms.  We have ensure vmq disabled on the broadcoms. tried the team in different configurations.  
We then erased our switch config and left it basic in ascess mode. Problem still present.

We have also tried an un-managed switch while the team is in independant mode.

We have also now setup the team in LACP on both nodes and negotiation established between node and switch (via team)

Current Setup is as follow :
LACP with mode=Dynamic team

Same setup on the team side where a vswitch "External" has the following networks :
Management : 192.168.0.x - Vlanid=2
Migration :  192.168.6.x - Vlanid=6
Cluster :    192.168.7.x - Vlanid=7

commands used to create the above :
#Creating vmswitch
New-VMSwitch -Name ”External” -MinimumBandwidthMode Weight -NetAdapterName “ConvergedTeam”

# networks
Add-VMNetworkAdapter -ManagementOS -Name “Management” -SwitchName “External”
Add-VMNetworkAdapter -ManagementOS -Name “Cluster” -SwitchName “External”
Add-VMNetworkAdapter -ManagementOS -Name “Migration” -SwitchName “External”

#Setting VLANID
Set-VMNetworkAdapterVlan -ManagementOS -VMNetworkAdapterName “Management” -Access -VlanId “2”
Set-VMNetworkAdapterVlan -ManagementOS -VMNetworkAdapterName “Migration” -Access -VlanId “6”
Set-VMNetworkAdapterVlan -ManagementOS -VMNetworkAdapterName “Cluster” -Access -VlanId “7”

# Min Bandwidth
Set-VMNetworkAdapter -ManagementOS -Name “Management” -MinimumBandwidthWeight “5”
Set-VMNetworkAdapter -ManagementOS -Name “Cluster” -MinimumBandwidthWeight “20”
Set-VMNetworkAdapter -ManagementOS -Name “Migration” -MinimumBandwidthWeight “30”

# and on the switch
Set-VMSwitch “External” -DefaultFlowMinimumBandwidthWeight “10”

On the switch I have done the following :
Created 2 port channels:

int port-channel1
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan all
  switchport mode trunk

On the interfaces I applied the following :
channel-group 1 mode active
and
channel-group 2 mode active


Also ensured on the switch I have
interface vlan 2
ip address 192.168.0.1 255.255.255.0
no shut

interface vlan 6
ip address 192.168.6.1 255.255.255.0
no shut

interface vlan 7
ip address 192.168.7.1 255.255.255.0
no shut

Show system mtu confirms the switch is only running at 1500 MTU (no jumbo frames)

Ensured Jumbo frames has been disabled on the converged team, the team members, the Virtual Adapters and finally the switch.


Still unable to ping / talk to other networks / nodes.
From any node, or from the switch, I am unable to ping any subnet 192.168.0.1 or 192.168.6.1 or 192.167.7.1
However, if I plug a laptop into a standard switch port, and assign that port to vlan2, I can ping 192.168.0.1 without a problem

Can anyone point me into the right direction?
any help is much appreciated
0
Comment
Question by:Sam Newbie
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 42

Accepted Solution

by:
kevinhsieh earned 2000 total points
ID: 40516936
I don't see that you have created the L2 VLANs on your switch.
#show vlans
#configure t
Vlan 2
Vlan 6
Vlan 7
End
#show vlans
0
 

Author Comment

by:Sam Newbie
ID: 40517086
Hi Kevin,
Thanks for your reply and apologies for my late reply. I managed to fix it the same day I posted the question but you are right, the Vlans were provisioned incorrectly and on top of that the Vswitch had reverted to Internal for some un-known reason.
Will mark as answer regardless.

Thanks again.
0
 

Author Closing Comment

by:Sam Newbie
ID: 40517087
To reply back while everyone is on holidays is amazing! Thank you!
0

Featured Post

Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It’s been over a month into 2017, and there is already a sophisticated Gmail phishing email making it rounds. New techniques and tactics, have given hackers a way to authentically impersonate your contacts.How it Works The attack works by targeti…
Optimized for private cloud infrastructures and datacenters, Nano Server is minimalistic, yet super-efficient, OS for services such as Hyper-V and Hyper-V cluster. Learn how you can easily deploy Nano Server and unlock its power!
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question