Solved

procmailrc not working when Maildir has permissions 700

Posted on 2014-12-24
1
334 Views
Last Modified: 2014-12-24
Hi,

I run a centos 7 mail server with Postfix, Maildir delivery using procmail, dovecot-deliver and roundcube
I try to use .procmailrc to send vacation replies.

When my $HOME/Maildir has 600 permissions $HOME/.procmailrc is working and vacation messages are sent but rouncube cannot display my mails, i get the error :
"imap error : failed: Permission denied (euid=1000(cyril) egid=45(mailusers) missing +x perm: /home/cyril/Maildir, dir owner missing perms)

When I put permissions 700 on Maildir, roundcube and imap are working but procmail doesn't deliver the vacation messages anymore.

my /etc/procmail :
# file: /etc/procmailrc
# system-wide settings for procmail
SHELL="/bin/bash"
SENDMAIL="/usr/sbin/sendmail -oi -t"
LOGFILE="/var/log/procmail.log"
DELIVER="/usr/libexec/dovecot/deliver"
# fallback:
UMASK=007
DEFAULT="$HOME/Maildir/"
MAILDIR="$HOME/Maildir/"
:0 w
* ^X-Spam-Status: Yes
| $DELIVER -m spam
:0 w
| $DELIVER



My .procmailrc :
#logging - in case you want to troubleshoot (uncomment by deleting #)
LOGFILE=$HOME/procmail.log
VERBOSE=yes
#
##shell - otherwise, nothing will happen when we call formail

  SHELL=/bin/sh
  UMASK=077
  DROPPRIVS="YES"
  LOGFILE=$HOME/procmail.log
  VERBOSE=on

  FROM='Cyril <cyril@test.eu>'
  SUBJECT=`formail -zcxSubject:`

  :0 Whc: vacation.lock
  * !^FROM_DAEMON
  * !^X-Loop: ${LOGNAME}@${HOST}
  | formail -rD 8192 vacation.cache

    :0 ehc
    | (formail -rI"Precedence: junk" \
      -I"Subject: Out of Office: ${SUBJECT}" \
      -I"From: ${FROM}" \
      -A"X-Loop: ${LOGNAME}@${HOST}" ; \
      cat ${HOME}/.vacation.message ; \
      echo ""; \
      cat ${HOME}/.signature \
    ) | $SENDMAIL -oi -t -f cyril@test.eu


Can you help ?
0
Comment
Question by:Cyril_M
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 

Accepted Solution

by:
Cyril_M earned 0 total points
ID: 40516152
Working with
INCLUDERC="$HOME/.procmailrc"
in /etc/procmailrc
when $HOME/Maildir has permissions 700

This line's not necessary wen Maildir has permissions 600.

Don't know why but it's working now.
0

Featured Post

Secure Your Active Directory - April 20, 2017

Active Directory plays a critical role in your company’s IT infrastructure and keeping it secure in today’s hacker-infested world is a must.
Microsoft published 300+ pages of guidance, but who has the time, money, and resources to implement? Register now to find an easier way.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
AWS Central Authentication 1 101
android secure ftp 3 68
bash file 10 62
blank screen when trying to setup Unity on Ubuntu 14.04 9 54
Network Interface Card (NIC) bonding, also known as link aggregation, NIC teaming and trunking, is an important concept to understand and implement in any environment where high availability is of concern. Using this feature, a server administrator …
Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question