After upgrade from 4.0 to 4.5 framework, my styles and images have disappeared on my website remotely

I have a windows web server 2008. I am using visual studio 2012. I upgraded my 4.0 asp.net web site to 4.5 framework. I updated the targetFramework="4.5" in the web.config.

I updated all my project's libraries to 4.5 framework in the properties. I ran a clean solution and then build solution. It looks great when run locally from VS2012.

I published to my webserver. Once I did, all my stylesheets are now ignored and my images are broken. They are still in the directories. They are still being referenced. No coding was changed. Just the framework.

if I look at my add/remove programs on the actual web server, it shows 4.5.1 framework, but no 4.0 framework; so it has to be using the 4.5 framework on the app pool.  In the apppool, the application is set to the 4.0 framework (which is the 4.5 framework).

So if anyone has any other ideas where I might be missing something that is causing it to ignore my styles, I'd appreciate any advice. Sorry, I can't provide a working example or send you to a web page to look at, so don't yell at me for not providing enough info. If I haven't I'm sorry. Just seeing if anyone has an "aha" moment.

thanks!
LVL 2
Starr DuskkASP.NET VB.NET DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kamal KhaleefaInformation Security SpecialistCommented:
make sure your application pool identity runs under network service

and all images and css files are exist

and the path is pointing to them
0
Ammar GaffarSoftware EngineerCommented:
I faced similar issue before, but the reason wasn't framework version, I just moved my application to another PC (Development Machine).

The problem was caused by IIS installation/configuration, I missed to select Static Content check box under Common HTTP Features.

See attached picture, applicable for Windows 7
IIS.png
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
King2002,

I changed the app pool identity to network service and I get a 500 internal server error. I changed it back and at least get the website.

Ammar,

This is a windows web server 2008. I looked for the screenshot you sent under turn Windows Features on and off and my screens are entirely different than that screen shot.

however, this is NOT a new webserver. I have numerous websites running actively on it and they work fine. So changing something in the computer settings wouldn't be the answer, because the majority of the sites on the server are fine. It is just this one site that I tried to upgrade from 4.0 to 4.5. My other sites, including other 4.5 sites, are working fine.

thanks!
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Miguel OzSoftware EngineerCommented:
Could you post the generated html for your image?
I am looking for any missing url information in the image. if that is the case you may have a mismatch on your assembly info.
Please create a new web app and add the same references and third party components of your app, then compare the config files of this new site with your affected site and check you have the same version info for all required assemblies.
Note: I have not used VS2012 before (jumped to VS2013 from VS2010) but  usually what I tend to do for all my apps  is create new projects and then add all files and references back to it.
0
Ammar GaffarSoftware EngineerCommented:
Are you using any third party components? if yes please list them.
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
Telerik Ajax suite of controls. But I am using them on other websites on this same server; as well as have always been using them on this website.
0
Miguel OzSoftware EngineerCommented:
As per my previous post
Could you post the generated html for your image?
Could you post your web.config file and a brand new VS2012 web.config file for version comparison?
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
I found the problem, somehow this was added to my web.config during the upgrade process:

<staticContent>
      <mimeMap fileExtension=".mp4" mimeType="video/mp4" />
      <mimeMap fileExtension=".m4v" mimeType="video/m4v" />
    </staticContent>

Open in new window


I commented those out and it works fine again. Don't know why it broke all my styles though. Hopefully I'll never need them. thanks!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
Okay, after re-reading Amar's post, maybe the "Static Content" checkbox is the issue. But I can't find that in my IIS. :(
0
Ammar GaffarSoftware EngineerCommented:
If you are hosting different sites in the same server and images are showing well then it is not because of this.
If not,  deploy simple site with only one page that contains image and then check
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
It was these mime types in the web.config
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.