Solved

Exchange 2013 / IIS Bindings

Posted on 2014-12-26
5
350 Views
Last Modified: 2014-12-26
When I attempt to open the ECP from the Exchange 2013 server, it defaults to this URL:
https://localhost/ecp/?ExchClientVer=15

And this is displayed:
There is a problem with this website’s security certificate.
 
The security certificate presented by this website was issued for a different website's address.

Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server.  
   
We recommend that you close this webpage and do not continue to this website.  
   
Recommended iconClick here to close this webpage.
 
Not recommended iconContinue to this website (not recommended).
                                  ________________________________________________________________

When I click 'Continue to this website(not recommended)'...the ECP opens in a webbrowser, and I can login.

How can I force IIS to use the FQDN of my Exchange server, instead of 'localhost' ?

PS I am using a SAN from GoDaddy, but don't have 'localhost' listed as a name on the certificate.

Thanks for any assistance rendered.
Cheers,
Robb
0
Comment
Question by:skypilott2
  • 2
  • 2
5 Comments
 
LVL 17

Expert Comment

by:Emmanuel Adebayo
ID: 40518926
Did you upgrade you Exchange or this is a new installation?

Check the link from the TechNet below
http://technet.microsoft.com/en-us/library/jj150562.aspx
0
 
LVL 33

Expert Comment

by:it_saige
ID: 40518945
The IIS site configured by Exchange, by default, creates a binding for:*: 80, 443 (Default Web Site)-and-*:81, 444 (Exchange Back End)You *should* be able to edit the * and localhost bindings on the Default Web Site to reflect the domains managed specifically by your SAN certificate.  But this is not a common, supported or recommended configuration.

-saige-
0
 

Author Comment

by:skypilott2
ID: 40518948
This is an Exchange 2013 Std on-premises server, upgraded to CU7 recently.
Using the document you linked, I ran PowerShell command to determine the following:

My internal URL for the ECP is:
Name        : ecp (Default Web Site)
InternalUrl : https://plato.pcutah.local/ecp

This URL works when I type it into a browser, but when I run the Exchange Admin Center applet directly on the Exchange server, it somehow defaults to the localhost URL I provided above. I can't figure out where it's getting that URL in IIS.
0
 
LVL 33

Accepted Solution

by:
it_saige earned 500 total points
ID: 40518954
You can change the properties of the shortcut:Capture.JPGCapture.JPG-saige-
0
 

Author Comment

by:skypilott2
ID: 40518969
Thank you, it_saige.
I was looking at all these different solutions, when the simplest one eluded me.
Many thanks for your help (and Emmanuel also)...problem solved by changing the shortcut.
Happy New Year!
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Deploying a Microsoft Access application in a Citrix environment is not difficult but takes a few steps. However, Citrix system people are often of little help, as they typically know next to nothing about Access. The script provided here will take …
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
Viewers will learn the different options available in the Backstage view in Excel 2013.
In this Micro Tutorial viewers will learn how to use Windows Server Backup to create full image of their system. Tutorial shows how to install Windows Server Backup Feature on Windows 2012R2 and how to configure scheduled Bare Metal Recovery backup.…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now